Error in Building Sample Application

Hi All,

i had installed EntireX(Trial Version 6.2.1) on my Linux(running RedHat 7.3) Machine.

when i tried to build “Hello RPC” Application provided by EntireX, i got the following error.



(cd unix ; make -f makefile)
make[1]: Entering directory /opt/sag/exx/v621/examples/msrpc/hello/server/unix'<BR>g++ -o /opt/sag/exx/v621/examples/bin/hellos ../../idl/unix/obj/i686_linux_libc6/hello_s.o \<BR> -g -uCoolMain \<BR> obj/i686_linux_libc6/hellos.o obj/i686_linux_libc6/hellop.o \<BR> -L/opt/sag/exx/v621/lib -lmutantstubs -L/opt/sag/exx/v621/lib -loleaut32 -lole32 -lrpcrt4 -lntrtl -lmutant -lcoolmisc -lpthread -lc -ldl<BR><BR><BR>/opt/sag/exx/v621/lib/ undefined reference to 'getpwent_r@GLIBC_2.1.2'<BR><BR>collect2: ld returned 1 exit status<BR><BR>make[1]: *** [/opt/sag/exx/v621/examples/bin/hellos] Error 1<BR>make[1]: Leaving directory /opt/sag/exx/v621/examples/msrpc/hello/server/unix’


i have also included “/opt/sag/exx/v621/lib” in /etc/ & ran “/sbin/ldconfig -v”, but i still get the same error.

if any body know how to correct the error,please let me know.

thanks in advance


Hello Ramesh,

If you take a look at it says that the prerequisite glibc is v2.2.2 and I see that in your case you are linking againest v2.1.2. So I suspect this may be the cause of the link problem. Is is possible to install glibc v222?

Hope this helps.

Stuart Fyffe-Collins
Software AG (UK) Ltd.


the released version of 6.2.1 will not run on RH 7.3. We had a customer who already noticed that, but in the end he didn’t wanted a patch cause he used 6.1.1.
We can exchange getpwent_r with getpwent (it is not critical in this case) and then it should run. Currently I don’t know how I can handle that with trial versions (for customers we could create a hotfix).
I will try to find out if there is a way to provide some updated binaries.

Volker Denkhaus


we will not have any updates for the 6.2.1 trial version.

Version 7.1.1 will be available for download in November.

Volker Denkhaus