Entire Connection

About June/July of this year, I finally got around to installing EC My old version was 4.3.2.

New version worked just fine at connecting to the mainframe from my PCs (desktop and lap top).

This past weekend, for the first time, I needed to download some programs from the mainframe. I tried several approaches (DSOURCE, DSYSTRANS, NATUNLDO). Always got the same error message about something missing.

So, I clicked on PROCS. Nothing. Looked in the appropriate (at least for the old version) folder; no subfolder for PROC.

Okay, the obvious assumption was that something was wrong with the install. Uninstalled 4.5.1 and re-installed it. No procs.

Finally, gave up, uninstalled 4.5.1 again and re-installed 4.3.2, which of course works fine for downloads.

Question. Outside of the different color scheme, what enhancements am I missing out on (SYSOBJH downloads?). Is it likely I received a bad CD? Was there some procedure I missed that would have been required to uninstall 4.3.2 then install 4.5.1?



P.S. had to re-submit this. Turns out that lap top as a single word is a restricted word. I had to change it above to two words. Hopefully this will be acceptable to the “bad language censor”. Am I missing something? Is this a “bad” word in some language?

Steve - I’ve had 4.5.1 installed for more than a year and hadn’t noticed the missing PROCs.

But I don’t have any problems doing downloads. Instead of starting with the procs, start SYSOBJH from whatever library. Or use LIST command with DL option on whatever ojects to download.

I had problems with using some xml functions and code pages that didn’t display (cent sign was one I vaguely recall). 4.5.1 provides more code page / extended character set support.

Hi Douglas;

First, thanks for the response.

Are you saying in your first sentence that you also do not have the Procs? If so, perhaps someone from Darmstadt should take a look at the install CD.

I think I will stay with 4.3.2 unless I have a need for some of the new code page facilities or ecs support.


my Procedures list was empty, so I went looking…

NCP files I found under the All Users Application Data folder. This will vary, if I recall correctly, depending on options you chose at installation time (all users versus “this user only”).

When you open the Configuration Manager, the first node is the path to your Share411.sag file. Right-click on the System icon in the right panel, Modify, select Procedure tab. Try setting the path to where your NCP files are located.

The settings in “System” are only defining default values. They will be used when new users will be created.
The folder for procedures is defined user dependent. So you have to click on “Users” in the tree control in the configuration manager. Select the user you are using on the right list control and choose Modify. Check in the ‘Procedure’ tab the entry of the procedure directory.

We can reproduce the problem, that the procedure folder is deleted in some cases, when upgrading from Entire Connection version 431 or 432 to version 451. It is going to be solved with the next version of Entire Connection which is PCC452.
Please contact your SAG representative or see SAGSIS 313255 for more information.

Thanks Norman;

I will wait for V 452. In the meanwhile I will just continue to use 432.