EDIINT Sender and Receiver not recognized by Cert Env

Hi,
I am testing an EDIINT scenario where the Sender is in Dev Env and Receiver in Cert Env. The Delivery Method is Primary HTTPS for Sender and Primary HTTP for Receiver since I am posting to Cert Extranet HTTPS port=443 and the url is HOST:443 for delivery to Receiver. HOST is our Cert Extranet.
When I use wm.EDIINT.sample:send service to send an EDI file, the transaction shows up in Dev with UserStatus=SendMsg:DONE while the Cert shows the Txn with Unknown Document Type and Unknown Senders and Receivers.

The Sender and Receiver Profiles in Dev and Cert are same.
Interestingly, when I post the EDI file to HOST:443/invoke/wm.tn/receive from TN WebManager, it shows up in Cert with X12 4010 850, Sender, Receiver but User Status=IGNORED, Activity Log shows: System status is DONE; user status is IGNORED.

The EDI file is located at
\packages\WmEDIINTSamples\pub\demo\small.edi.txt and also attached with this post.

Any help wud be appreciated.
Thanks
small edi.txt (14.5 KB)
inputsForSend.txt (890 Bytes)
ContentIMAGEInsideDoc.zip (19.5 KB)

I believe you should post AS2 to this url:

https://HOST:443/invoke/wm.EDIINT/receive

Hi rmg,
True, when i do that i use the URL: wm.tn instead of wm.EDIINT (via WmTNWeb page) to successfully post to my Cert Extranet which finally gets thru to the Internal Cert Server although with an IGNORED status.

However, i tried according to ur suggestion with wm.EDIINT - it does not reach Internal Server :frowning: It’s an EDI 4010 850 file as attached with my post.

But when I do using EDIINT:send service, I see the Txn in Dev but it is shown with Unknown parameters in Cert. I request you to go through attached screenshots/files which may clarify my issue.

Appreciate ur response :slight_smile:

Any error you see with EDIINT receive in the source/target logs and why its not going thru?

Is your DMZ/reverse http gateway configuration to internal ports working thru?

HTH,
RMG

I don’t see any logs in source/target.
But DMZ<–Internal is working since when i post using WmTNWeb the Txn shows up in Internal Cert.

Also, while creating demo from wmEDIINTSamples (TN profiles) i had removed the Certificates since they are expired and I am testing with:

<?xml version="1.0" encoding="UTF-8"?> packages/WmEDIINTSamples/pub/demo/small.edi.txt application/edi-x12 [B]plain [/b] false PrimaryHTTPS none <[B]value name="requestSignedReceipt">false [/b] Sender AS2 EDIINT AS2 Receiver AS2 EDIINT AS2

You should always try with EDIINT receive not with tn:receive…Can you also try with primary http with regular port?

will try n let u know. thanks

Hi rmg,
You are right. I see the Txn in Cert with wm.EDIINT:receive in the Delivery method for Sender and Receiver.

Would get back to u if I have some other bottlenecks. At present message is ProcessMsg:ERROR with insufficient message security.

Thanks
Shaanz

good deal:

I set S/MIME in Extended Settings as plain and the insufficient-message-security went away since the default for S/MIME is signedANdEncrypted while I am using plain message.

Yes you got it: