EDI TRADACOM DocumentType Issue

Dear all,

I need quick and urgent help form this forum who all have knowledge on EDIINT Europe EDIFACT ie EDI standard documentType “TRADACOMS 9 ORDHDR”.

TN Standard documentType " TRADACOMS 9 ORDHDR" is not getting Invoke.

Issue:
while i am trying to send standard EDIINT tradacoms 9 ORDHDR document to TN instead of recognizing TRADACOMS 9 ORDHDR documenttype in TN it’s invoking default documentType “EDIINT”

May i know what data type is missing in attached document.
appreciate you response !

Have you installed the TRADACOMS 9 ORDHDR doctype and schema and shows up in TNC?

Please check your custom TRADACOM rule is above the default rule (do step up):

HTH,
RMG

You are correct i have installed TRADACOMS 9 ORDHDR docuTYpe and schema in my IS and show up in TNC as well as i have created processing rule to identify document type but still processing rule is not getting invoke and doctype is identify is “EDIINT” and i am using AS2 connection

according to the EDIINT user guide, the content type for Tradacoms should be:
application/edi-consent
hope this will fix your problem

Hi,
I think Content-type should be application/edi-x12.

Regards,
Shashank.

Indeed but still transaction is unable to recognize documentType in Trading Network Console with contentType = application/edi-x12 when i send above attached Tradacoms 9 ORDHDR In sender and receiver partner profile is getting recognize but actual DocumentType “Tradacoms 9 ORDHDR” is unable to recognize it’s selecting default document Type in TN Console “EDIINT”.

It means the payload is not getting extracted to TN…Do you see any error on the EDIINT transaction Activity Log?

Also check int he EDIINT homepage if the submit payload to TN is checked?

HTH,
RMG

Hi,
When I routed the attached document on to my TN using IS → EDI Module → Doc Exchange → Submit Test EDI Data

TRADACOMS Transmission is the TN document type which is getting recognized. Note that I have TRADACOMS 9 ORDHDR installed on my B2B IS.

It has used default TPA - EDI TPA.

Regards,
Shashank

He is doing via EDIINT and thus this issue while extracting payload it seems:

Shashank & rmg,

I like to mention few more details i am getting EDI messages via RI AS2 connection so i too believe tht i am having issue with EDIINT payload in TN. while GXS team sending message with sign&encrypted format.here is my TN profile setting look like sender A and receiver B TN profile, IN A profile Extended Field S/MIME"sing&encrypted" and GXS certificate installed and B Profile S/MIME"plain" with our Orgn certificate installed we have done hand shake of certificate as well and i have tried with all test cases by modifying profiles A & B S/MIME setting 1 sign&encrypted plain → same result
2 sign&encrypted sign&encrypted → same result 3 plain plain → same result.i am able to see EDINT and EDINT MDN message in TN but can’t able to recognize TRADACOMS 9 ORDHDR documentType with processing rule.Find the TN Console screen short for EDIINT and EDIINT MDN activity logs

URL: https://docs.google.com/document/d/121vh_8AIwixAfUW2TUIEDNv9mBqJx0Ggs7RbGFpeU9c/edit?hl=en_US

br,
RJ

Added Few More information.

A Sender Profile Using Extended Fields.
Algorithm TripleDES
S/MIME Sign&Encrypted
received Certificate from source Installed in TN
exchange our CA and Client cert

B Receiver Profile Using Extend Fields
Algorithm TripleDES
S/MIME Plain
send our orgn certificate to them and installed our Orgn CA and Client with Private Key in TN

Thnx
RJ

Shashank & Rmg,

Can you guys please look into this Issue " Payload is not getting extracted or processed" have attached all screen short from my TN Console.

Regd
RJ

Setting looks standard/appropriate…But you would have to troubleshoot with your TP and check the network/logs behind the scenes also:

HTH,
RMG

Are you testing this internally or with TP also?

please raise a ticket with SAG tech support also:

Thank RMG,

i have few more business transaction with same setup and it’s working fine only difference it that TN profile is set with S/MIME = plain and payload data is processing fine without any issue but in this case we are getting sign&encrypted data where certificate handshake is done and S/MIME is set to sign&encrypted format.
while i am sending plain data from my local IS to TN console → work fine but when i set my TN profile and set to sign&encrypted installed certificate To and Fro getting exception as " Error encountered in wm.tn.security:getSigningKeyAndChain. Private key not defined. Please call wm.tn.security:getVerifyingChain" but private key is define very well in TN.

Are you testing this internally or with TP also?
yeah i am doing end to end testing with extenal TP as well but getting
transaction in TN Console as show in attached screen shot.
1 EDIINT
2 positive EDIINT MDN

but somewhere actual documentType is missing “TRADACOMS 9 ORDHDR” which invoke processing rule.

External TP sending data with sign&encrypted format in following ContentType
application/edi-x12
application/edifact
application/octet-stream
application/tradacoms
application/xml

You tryied every possible way I guess…Please contact SAG tech support to fast track on this issue:

HTH,
RMG