Error Invalid input URIString%09EDIINT000001000003 while using wmEDIINTsend

I am send an EDI x12 document by calling the wm.EDIINT:send service. The document gets to my Trading Networks and ends with a “Done with errors” status. The detailed error reads :
“Delivery service for 4acd9h00vp2mg4m10000000r failed with a status of fail and status message of Invalid input - URIString[EDIINT.000001.000003]”
Has anyone had this problem?


Can you provide us what are the different inputs you are passing to EDIINT:send service from the IS flow.

I believe the deliveryMethod you selected in the send service is failing when referring to setting in the DeliveryMethod tab of the partners profile.
Please check the specified URL,DeliveryMethod configured in the ProcessingAction.


Hello HTH,
Thanks for your help. I did find wrong uri info in the delivery methods tab. So now I am able to send the message.
How ever I have noticed a new problem. I am using digital certs to perform message exchange with my Trading Partner. Both of us do not have any thing specificed in the Verify Sub tab of the security section in the profile config. Is this required to use digital certs? I an EDIINT message and I get a MDN back with a status of ERROR and that this MDN is not signed. Any thoughts?


Glad that URIString problem solved.

yes,you need to specify the digital certs information in the Verify Sub tab of the security section in the corresponding Partner Profile config if you are using HTTPS SSL handshaking for EDIINT AS2,MDN inbound/outbound encryption/signed message.

Otherwise if you want to ignore this security thing then in the EDIINT:send service itself set input requestSignedReceipt = false(you request a plain MDN back from partner)or true if requires singed MDN and this uses digital certs.


I don’t necessarly need to config HTTPS for just digital encryption and signing, do I?
When I call the send service now I am getting “Task 4acd9h00vp4v7mvs0000002k failed with no more retries available. Reason for failure - Delivery service for 4acd9h00vp4v7mvs0000002k failed with a status of fail and status message of [ISC.0064.9306] Connection was closed during read”

There is no reason for the connection to be closed I am able to reach the IS for the trading partner server via the admin screen. I am spinning in circles here thanks for your help RMG.

you are right,there is no need of configuring HTTPS port for just digital encryption/signed messages.But you must specify the things in the TN which i mentioned above.

I will let you know if any clue for the error you are getting.


Dear RMG,

I set the URLs and the delivary methods correctly. Yet am getting the same error.

Delivary Mode - Primary HTTPS

Any suggestiongs?


I use certificates and only use the Primary HTTP method type. I have set both the encrypt and verify tabs under the partner to use the same certificate. In my custom send service, I do as RMG has mentioned as be ask for a Signed receipt. If you want more help you will have to be more elaborate with what you send to the service for “all” the inputs. I use WM 6.0.1 SP2, so I am not sure of differences between other versions.

Thank you. It worked for me.

Glad to hear it worked out: