Drop Down Problems

I have a table that contains several columns.

Some of this columns are editable and I placed there Drop Down controls

However when I place more than 3 drop downs and add try to add one row the screen appears with a “Loading” and nevers get out, the processor stays with 100% so I imagine theres a infinite loop .

Any idea how to solve this?


I found that the problem occurs when I change the width of the controls, e.g. form input20 to input8

Would it be possible to supply an isolated project that demonstrates this bug?



I tried to make a small example and it worked all ok.

However the problem remain in my project.

I sent in attachment the view that contains this problem. If you look by the table V_DCD_DET_TABLE_ID and asyncTable2 you will find there some collumns with dropdowns and other with text input other with text az. I made more test (since this is currently a blocking point for me) and found that the problem is not only realated with the size but with the number of input controls, I mean if I set render=false the input elements it work ok, if I set render = true to all input it breaks (probably some endless loop in the code located in the browser).
CriarDecVendaDetalhe.zip (14.2 KB)

I can’t run that .view file so i’m not entirely certain, but i wouldn’t be surprised if the problem has to do with multiple input fields in a single column. I haven’t seen that pattern before, and that might be responsible for the problem you are seeing.


Are the dropdown values static or dynamic. When i say dynamic, do you fetch the values from a JDBC call. If yes, then that could be a reason too.


Finally the problem was solved.

So the problem was related to the sorting capability. There were changes
in the API (IS API of your application) and the sort field stayed with the old
bindings. After the correction of all, it started to work normally.

PS: It’s possible to have several controls inside the same column, we use it a lot.

Thanks a lot for you help,

Apparently, I was to optimistic.

So I still have the same problem.

This problem only occurs in the IE, in Chrome and Mozzila works ok.

New Tests that I’ve made and it still DO NOT work:

  • I have only one dropdown by column
  • I changed the dropdown to TextInput
  • I can not have more than 6 columns in a table

Just to clarify, are you saying that the following doesn’t work?

Table w/more than 6 columns.
Each column has a TextInput Control.

The table won’t render.

Is that a correct summary?

Just one minor correction.

Basically the table contains columns with TextAz controls and other columns with Input Text. The problem occurs when I added the 6 input column

I wasn’t able to reproduce the problem, but i have attached a simple project that has one text output control and six text input controls. Would it be possible to try to manipulate this project to generate the error condition?

TooManyInputsApp.zip (10 KB)