Deploy TN doctype definition from 7.x to 9.x

Hello Experts,

we need to move a number of TN Document Type from 7.x to 9.x.

At the begining this seams to be a easy task by after trying to few different ways none worked properly:

  • deployer to pull 9.x from 7.x filters dosn’t work because IS & TN 7.x source is filtered out by deployer in the forst place
  • deployer to push 7.x to 9.x do: we have an error on deploy: wm do not support this TN Document types migration
  • export from TNC 7.x and import to MWS 9.x import some document type by external ids are wrong

Have anyone completed a similar task or want to share their experience?


Hi Sorin,

As you realized, the first two options are not officially supported, but the third option is supported. However, you said there are problems with External ID’s, and I guess the reason could be, you did a fresh install of 9.x separately and tried to move 7.x assets to 9.x where in this clashes with External id’s for few pre-defined documents as they are different between 7.x and 9.x (for eg., EDI related).

Can you try the following to make it work smooth?

  1. Take backup of 7.x TN database schema and restore it with different name in database (making another copy of source db schema).
  2. Assume you are on 7.1.3 version and not on 7.1 or 7.1.2. If you are not in 7.1.3, check if there is any CDC script provided part of 7.1.3v.
  3. From your 9.x installation, run Database component configurator tool and point to the db schema (restored with different name).
  4. Choose migrate option, and from drop down choose the version as latest.
  5. If you have your installation in Unix systems, use commands to perform this migration.

Now the TN tables installed part of 7.x is migrated to 9.x. These tables cannot be used by 7.x TN instance, where as they can be used by 9.x TN instance… Point your TN to this schema… If you face any issues in between, you can post here.

Hope this helps…


Before going with above steps suggested by Senthil

Can you import the TN assets in WmTN/bin/init.xml from MWS in 9.x and then try your third option(export from TNC 7.x and import to MWS 9.x import some document type by external ids are wrong)
to see if it is working?


Thank you for answering

It seams that DB upgrade is the only way, I will let you know how we work it out


That’s the cleaner way, and hopefully you shouldn’t face any problem once migrated successfully. Please follow above steps described (for migration using db) and any additional steps that is required (if missed above) let us know how it goes.