Cumulocity IoT - Free Trial Error

What product/components do you use and which version/fix level?

Cumulocity IoT from website

Are you using a free trial or a product with a customer license?

free trial

What are trying to achieve? Please describe in detail.

I am doing my training and created a simulator device and integrated it with web method io and snowflake.

Do you get any error messages? Please provide a full error message screenshot and log file.

It worked good on first day. Second day whenever I am trying to access device, I got error stating 'Token not present for ‘myenvironment/username’. I tried multiple times by logging out and loggin in and even one day after it didn’t work. So I stopped the free trial account and tried to add a new trial account. Then I am getting error ‘some error occured please try again’. I created a new environment and login in softwareag.cloud to freshly start a new trial account, but even there I am getting same error ‘some error occured please try again’

Have you installed latest fixes for the products

Hi,

can you provide more details about your environment: URL and tenant name. I would forward this information to support to have them look into your issue.

Best regards
Christian

Hi,
Thank you for the response. My environment url is ‘snowlearn.softwareag.cloud’ ,
cumulocity url was ‘snowlearn.us.cumulocity
and tenant_uid=fla7cd32a9aae78132cee5d6
As I mentioned before I stopped the trail in this environment since I was repeatedly getting the error and tried from a new enviroment ‘mysnowlearn.softwareag.cloud’ where also I got error.

Now from today, I noted that the error message for my first environment (snowlearn) is changed, now it is showing
You already have a Cumulocity IoT free trial, or you have triggered the process of starting or stopping a Cumulocity IoT free trial. Please check and try again later.
But I actually stopped it a few days back and trying to start a new trial, which it is not allowing me.

Regards,
Reeshil

My environment is env429464 and User is jeff4smith@gmail.com.

Still I am unable to add a trial account in existing / new environments. Now in all environments, I am getting the error ’ You already have a Cumulocity IoT free trial, or you have triggered the process of starting or stopping a Cumulocity IoT free trial. Please check and try again later.’. I tried to do everything afresh again with a new environment, env256123.softwareag.cloud. There is showed that your subscription is being setup, but it didn’t appear and again started showing above error. So now I am fully stuck without knowing how to proceed further. I need at least one working environment to proceed. Preferably my first environment '(snowlearn.softwareag.cloud) as I already made some work with web method integrations there.

Hi,

I’ve got the same problem.
Environment URL: env180149.softwareag.cloud
My username is vi.pham@dounets.com
In my environment, even though there is no trial added to my cloud, I am getting the error “You already have a Cumulocity IoT free trial, or you have triggered the process of starting or stopping a Cumulocity IoT free trial. Please check and try again later.
I tried to refresh the page or create a new environment with new account but still encountered the same problem.

Hi all,

I have informed support about your issues and forwarded the details. I will keep you updated.

Best regards
Christian

2 Likes

Hi @vi.pham @jeff4smith Can you explain the whole set of actions you did?

I just tested with a brand new account and everything worked as expected. I was able to start both a Cumulocity IoT Free Trial and some others (webMethods.io Integration, API) and didn’t get any error.

Next I stopped the Cumulocity IoT Free Trial
image
and was not able to start a new one. Take into account that stopping the Cumulocity IoT Free Trial destroys the whole environment (it’s not like a restart of the system like some users seem to think). And currently after that a new trial cannot be started with the same account. You will need to create a new account.
Can you confirm that is what happened - you stopped the Trial and got the error after trying to start it again?

@toni.petrov In my case I was initially getting an error whenever I was trying to access my existing trial account and that is why I stopped my existing trial. Then I created a new environment and started seeing same error in both environment. But yesterday I was able to click and proceed start a new trial in new account without any error, but that account was never available for me and then I started getting error that I already have an account. So I created a completely new account (all the 3 environment names are listed in my post above). In the third account as well I was able to click add a trail without any error and it showed that new subscription is being setup. But again it never became available in my new account and after that whenever I click add a trial again it shows error. So basically in none of the 3 environments I created I have a cumulocity trial available. Only in the first environment I stopped a trial where I had done some work. But in other 2, the accounts never became available to me.

hi @toni.petrov
I just created a demo of what I experienced before. I did it with a newly created account and it still occurred to me. Here are the steps that I did

  • Step 1: choose Start trial of Cumulocity IoT → Cumulocity IoT is added to my cloud products and is being set up
  • Step 2: I do nothing but wait for it and then suddenly Cumulocity IoT doesn’t appear in my cloud product anymore
  • Step 3: I choose Start trial again → Get the error message

I tried to attach a video link of my demo but it seemed that it wasn’t allowed…

Hi,

support is aware that there is an issue with the existing Cumulocity Free Trial tenants and also new ones. They are currently investigating the root cause of this issue.

Best regards
Christian

Hi Everyone,

The issue has been resolved and you should be able to set up a new Cumullocity IoT Free Trial on a new user account now.

Thank you for your patience!

1 Like

Thank you! It worked!

1 Like

I successfully added trial to my cloud. Thank you, y’all!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.