ARG2007: Cant open the Tamino branch on SMH


I have installed Tamino and am able to log on to the SMH as “Administrator” (which is not even a user on the computer). But when i try to access the Tamino branch in the SMH to create a new database, it give me the ARG2007 (The user does not have enough rights to execute this command).

I found some posts that mentioned that the login name has to be of the format ./ where userid is a user of the computer with administrative rights. My problem is that my computer is not part of a domain. How do i log on to the SMH in order to be able to have admin priveleges and to create a database.



If you not using any domain concept, you need not to specify a domain name for the SMH / Tamino Manager login. You can specify / to logo on to the SMH.
But the user must be the one (for the first login time) who installed Tamino and msut have full admin rights.
Check if the user id you are using is the one of the install and if it had full admin rights at the installation time, if so, please use this as described above.

kind regards


let me explain clearly again. The computer is not a member of any domain (we use a windows workgroup only). The user name is “IMF” (we checked that this is the only administrator rights user on the machine and that tamino was installed using this account, the registry entry also suggests the same) and we tried logging on to the SMH using only “IMF” as the user name and its password. It popped up a message box saying Invalid username or password.

Like ie said, i was able to log on as “Administrator” as the user name. In this case I was able to check under hostname → SMH → Tamino → Administrators and it lists the user IMF as the administrator. But it still doesn’t let me navigate to the main Tamino branch from where the database can be created giving me the ARG2007 error.


1. please tell me the Tamino version.
2. From your explanation: you have installed the product under the uid=IMF and defined IMF as Tamino administrator. Then you try to login to the Tamino manager using uid=IMF and his password but the system don’t allow the login. This problem must be solved first. You can start working with the system only if you can login as IMF, since this was the initial Tamino administrator defined on installation time. Please recheck the uid’s and the security policy on your local system for the user IMF.
3. How you can login as “Administrator” if this uid don’t exist on the local system? If the local system is not part of a domain, you can login only using a valid local uid/psw. Please explain.

Best Regards
Cristian Bettendorf
Software AG

I have exactly the same problem as metamutator.Im on a workgropu as well…how did you solve it please?I have the latest tamino!

Arsenal are the best!


I had the same problem as well. I installed Tamino with a user that’s not part of any domain. Actually we here do not have a domain but a workgroup.

I opened SMH and logged in with a user with administrative rights. Login was succesful but when i managed to create a database i faced the above mentioned error.

Then i tried the same process with different users. It seemed as it was not matter what i did login with. The system was accepting any users[even the ones which were not defined on my computer!] but not letting them create a database.

Then i had a look at the registry, added a new user which is defined on my computer and with administrative rights. It worked…

The path to the registry entry is as follows :
HKEY_LOCAL_MACHINE > SOFTWARE > Software AG > System Management Hub > Products > Tamino > Users

Just add a new key with with the same name of the user.