X-Node to MS SQL_Server over ODBC

I would like to retrieve data over ODBC from my SQL-Server 2000 database. Unfortunately I’m not able to define the schema with the Schema Editor.

My definitions look as follows:
schema:MXS (schema name on SQL-Server)
datasource:Microsoft SQL Server:MXS

The Schema Editor complains with the follwing error message

oops, I posted the message before I finished it properly:

Of course, I also provided the table name.

The schema editor complained with an error message INOXDE7952.

Does anybody know, what’s wrong with my definition. Does anybody have a good example how to access a ODBC database over X-Node, e.g. the Northwind database.

Thanks for suggestions. rene

which version do you use? I succeed in accessing ( :wink: ) Northwind-DB with V2.3 and V3.1.

Hi Uli,

we use version Can you send me the exact ODBC connect string you’re using?

Thanks for your support. rene.foehn@powerware.ch

Hi Rene,
I defined a System DSN with the name “NorthWind”. This name is then used in root node of the schema as the datasource.
See attached file!

ODBCSchemaToNorthwind.tsd (6.06 KB)

Hi Uli,

thanks for the tsd, but unfortunately this solution crashes my database. The only thing I changed was the collection name. I defined an ODBC DSN for my Northwind database. I tried both the Access and the SQL-Server 2000 version. Either solution crashed my database instance, or it was not able to log into the database.

I have serious doubts that Tamino is a stable and robust product, when a tiny tool or application like an ODBC connection is able to bring down a server.
At the moment I’m not sure if I should leave X-Node and import my external data over an offline importing tool.


Hi Rene,

There is a known bug when defining a TSD schema with ODBC mapping solved with hotfix #3. Please contact your local Software AG customer support to obtain this fix.

Kind regards, Stuart

I received the Tamino patch from my local Tamino customer support. I was told to stop the Tamino Event Service before installing the patch. Everything works fine, but what makes me curious is that the version of this service was from an older installation (Tamino\bin\evtdmn.exe).
On the new Tamino version I could not found this service in the bin directory, and even when I stop the service my database seems still to run. What is the purpose of this service? Is it no longer be needed by version 3.1?

Thanks, ren