webMethods 9.8 Designer Local Service Development with Git

Hi All,

I know this topic has probably been answered before, but I haven’t actually found a step by step guide on how to setup Designer Workstation with Local Service Development and use Git.

I have a repository stored in Atlassian Stash, installed Designer Workstation and have configured EGit.
I’d like to know the steps of working on an existing package in my Git repository in my local IS. After reading the Service Development Help, it states that when you import the project into Eclipse and then right-click and say “Move Package to Local IS” it actually is meant to copy the package to the instances/default/packages folder, but I’m seeing it actually move it, thus showing a delete in the git status on the original repository.

If someone could provide a step-by-step guide as to how to

  1. Setup local IS with a Git repo
  2. Configure the remotes on the local repo to do a fetch/push
  3. Copy an existing package from a remote repository into Local IS
  4. Commit changes made to the above to the local repository and then push them to the remote Repository
  5. Create new package in local IS and push it to the remote repository



So I finally solved this by upgrading Designer to v9.12

Local Machine
In a terminal, run the following

# replace firstName and lastName with your own details
git config --global user.name "yourName"
git config --global user.email "yourEmail"

Importing Git packages to IS

  • Open Designer
  • Go to the Preferences and select the Local Service Development
  • Ensure both boxes are ticked
  • Open the Git perspective and click on Clone Repository and enter the details
  • Select the correct branch
  • Select a folder to clone the repository into and set the initial branch
  • Before you import any packages, ensure that you turn off the build automatically, otherwise the Java services will recompile and it’ll
    display as changed
  • Now you can import the packages into your instances in the Git view, by right-clicking package and Import Project
  • Go to the Project Explorer perspective
  • Right click on your package and select “Move to Project to IS package”
  • You should now see the package in your local instance along with the repo/branch it’s using

Deleting packages from local IS, but leaving in repository

  • In Package Navigator view, right-click a local service development project and select Team > Disconnect
  • Navigate to the Project Explorer and Delete the project associated, but ensure that you don’t delete from disk
  • Go to the filesystem (C:\opt\webMethods912\IntegrationServer\instances\default\packages) and delete the package shortcut there
  • Go to the IS Admin screen and delete the package

I hope this helps everyone out as it was a struggle to get anywhere with SAG support on v9.8.

DPT-EAI-GitandwebMethods-281116-0331-280.pdf (343 KB)

1 Like

How do I get existing code from my local machine into an empty repository?

I don’t see the Create Local Service Development menu option that’s in the PDF.

Do you have Designer Workstation installed? If not, you won’t get that option.

Hi Aditya, is there the possiblity to connect designer to bitbucket without the service local development plugin?

Hi Francesco,

should be possible as long as Eclipse provides a plugin for bitbucket.

But without LocalServiceDevelopment you will not be able to check in/out IntegrationServer assets directly from Designer.


i am new to webmethods, today downloaded trial version and installed ,designer service development perspective is not enabled please help me how to set designer in service development mode .

Have you installed all required Designer components ? like local service development?

Hi Yogesh,

I am not sure , i have just installed with given image file please find attachment for installed features.

Hi Chandra,

Can you try to run installer again and see if the highlighted (in screenshot) component is installed or not. Seems like webMethods service development is not installed


Hi Yogesh,

Thanks for your response, could you please send me download link for webmethods integration, i have downloaded natural webmethods integration file and installed so i could not get service development option this installer may be wrong. i have just now download webMFREEDownload10(Win64bit).zip this does not have any installer or exe . please find attached image for downloded option.

Hi Yogesh,

I could able to install finally, but in service development perspective i need palletts for that i went to the path(-windows-showview-others-General-pallets ) and clicked pallets ,but getting a pallete is not available message please advice me

Hi Chandrra,

can you explain your current issue more detailed please?
Which pallets (I think you meant palettes) are you looking for?


Hi Aditya,

I have a similar requirement as yours,

  1. Having a repository created in Stash.
  2. webMethods 9.12 installed with Designer git plugins in place.
  3. I was able to proceed until user set up in local Designer.
  4. If i have new packages all everything is a new set up, and my repository is empty, there are no branches to import the packages. How to get the IS packages to BitBucket and Git local repository?
  5. I think am missing a piece of action in this process.

Can you please clarify ?

I am facing issue while cloning the package from github.
I am following all the steps and the project is also moved to package explorer but , while clicking on “Move the project to IS package” , it is not getting moved . No logs in error, server also.
I am using 10.3 and Git hub as VCS.

Is there any setting which I am missing.

FYI…I am able to push package from my local to Git hub.

Hi All,
I’ve followed instructions from the pdf attached and “Integrating Software AG Designer and webMethods Asset Build Environment
with GIT” but for both, i’m stuck at the step ‘Move Project to IS package’. It’s disabled.

Env: wM 10.1
Git for windows
OS: Windows 10
(Run as Admin)

I’ve removed the project file, recreated via Configure -> Convert project as Local Service Development but no luck. The option remains disabled. Any suggestions?
Screenshot 2019-04-08_13-44-56-860.png

This should get resolved by launching your Designer as admin