"Unable to get metadata.". "

hai to all, when i am trying to enable my adapter notification i got the following error…Adapter Runtime (Notification): Error in Notification Callback:enableCallback notification tn:testAckwn.
[ADA.1.316] Cannot execute the SQL statement “Unable to get metadata.”. "
(17008) Closed Connection"
Closed Connection

Any suggestions please to overcome it…

              I am using 7.1.1 version and i have correctly enabled the adapter connection wich i am using for this notification...

Hello,
This error comes when your DB is not connected, or there is some connection issue.
Try checking in the JDBC Pools and test the connections.
Also, edit the settings of the adapter notification first, before enabling it.

Adapter Notification uses JDBC adapter connection information to connect not JDBC pools connection.

This is perfectly true…
But, if the JDBC Pool is not configured for Adapters function, it will not work and the same error is thrown.
This is a tested thing and I have solved this problem by configuring the pool and restarting IS and DB also.

Suvigya,

How did you test this theory? Can you please elaborate?

Rajesh,

Apply the latest JDBC Adapter fix to resolve this issue. This is an old known issue.

JDBC_6-5_Fix3 addresses the follwing issue:

  • fail to enable notification with [ADA.1.316] Cannot execute the SQL statement “Unable to get metadata.”. "
    (17008) Closed Connection" error.

https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1614053536

Cheers,
Akshith

What are the configuration settings for the JDBC connection?

I usually see errors like this when the minimum connections is not 0. The connection pool maintains a connection which the DB has closed. Then the first operation that tries to use the connection gets an error.

hai ,

 thank to all for your replys....

Akshith i will try to fix it by applying the fix you have said to me…

Suvigya…

I have configured the pools exactly and i think there is no issue with the pools and jdbc connection… I will check it once and let you know…

To solve this problem we have deleted the Trigger,sequence,buffer tables for the notification we are enabling and after this the problem was fixed…but i think this is not a permeanent solution …so i need your suggestions…

hi Rajesh,

As suggested by Rob, this problem could be because of closed connection in connection pool (wM holds the connections in pool though those are closed by db in case of timeout or restart). Try to set the Minimum connections to 0.

Another reason could be that, if you are using insert/update/delete notifications wM creates triggers and buffer tables when the notification is enabled and drops then when disabled. Say when the notification gets disabled when the connection is closed, the trigger/buffertable db objects wont get dropped, but when you try to enable the notification later wM creates these objects again - sometimes resulting in error (though am not very sure of this scenario). Someone experienced this, should explain this :slight_smile:

-regards
DC

hey Remon n deepan thanks for your replys …solved…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.