Problem enabling an Adapter Notification after upgrading from 6.03 to 6.5


We are in the process of upgrading out IS from WM 6.1 to 6.5. We are also upgrading the OS from Windows to AIX 5.3. We decided to upgrade the JDBC Adapter from 603 to 6.5. When I try enabling any of our Adapter Notifications I get the following error:

[ART.116.3038] Adapter Runtime (Notification): Error in Notification Callback:enableCallback notification Z_Stran.POC:testSTNotification.
[ADA.1.316] Cannot execute the SQL statement “Unable to get metadata.”. "
(17008) Closed Connection"
Closed Connection

We are hitting an Oracle 9i database.

I even tried creating an adapter notification from scratch and still get the same error.

Any suggestions??



Did you resolve your issue?


Yes we did. We had some DB issues that have since been resolved.


We are also getting the same errors when trying to enable these notifications, Suzette do u recall what DB patches, actions u took to resolve this issue. Also opened an SR just in case as the current resolution from advantage is not good enough.


Since we imported all our tables from an existing 6.1 environment,
we had to go into the database where the notifications were trying to create and manually delete all the sequence, trigger, and the buffer tables associated with that notification. Once we did that and re-enabled the notification, it worked.

Hope this helps.


Thansk Suzette for the prompt feedback, in our case its a new installation so there is no migration issue here. However I just received a word from wM Support about a bug in jdbc adapter 6.5 and received fix#3. Just tried it and it seems to be working. Here is some more info from that fix:

Enabling adapter notification on DB2-OS390 with webMethods JDBC
Adapter 6.5 results in the following error:
“[ART.116.3038]Adapter Runtime (Notification): Error in
Notification Callback: enableCallback notification…
[ADA.1.316] Cannot execute the SQL statement “Unable to get
metadata” (42501/-551) DB2 SQL error: SQLCODE: -551 SQLSTATE:

“In JDBC adapter 6.5 version, a “improved polling notification
mechanism” feature was added. During enabling a notification,
this feature validates if the database objects to be created for
the notification (such as buffer table, trigger, etc.) are
already present. If so, then it does not allow you to enable the
notification, and throws an error. In this case, the problem
occurs because the user does not have permissions to execute the
query that retrieves the list of existing triggers. That is why
“SELECT * FROM SYSIBM.SYSTRIGGERS” cannot be executed.”


we are getting the following error when trying to enable an insert notification:
[ART.116.3038] Adapter Runtime (Notification): Error in Notification Callback:enableCallback notification UTCFS_CoEx_POC.Notifications:Insert_F4211.
[ADA.1.316] Cannot execute the SQL statement “Unable to get metadata.”. "
(42704/-204) [SQL0204] SYSTRIGGERS in FPYNADTA type *FILE not found."
[SQL0204] SYSTRIGGERS in FPYNADTA type *FILE not found.

We thought SYSTRIGGERS was showing up due to the lack of jdbc adap fix 14.However installing the fix did not solve the problem.
Can someone throw some light on this?..Thanks in advance:)

Please follow the directions given above by Suzette and Adnan. I think you manually need to delete the already created database objects.


Thanks for your suggestions,but we just managed to solve the problem with some help from Oracle support.We made the following changes to the other properties :

We are now able to enable all the notifications…hope this would help anyone facing similar issues.