Unable to deploy "Default" Package from 8.2 to 8.0

Hello Techies,

We tried to take Archival (tried Full and Patch release both) of a “Default” package from SourceServer (8.2.1.0) and tried to deploy it to Target Server (8.0.1.0).

While deployment it gives a below error :

Error log for Patch Release :
wm.server.packages:packageInstall No enum const class com.wm.lang.ns.NSWSDescriptor$Version._8_2
Error Log for Full Release :
wm.server.packages:packageReload No enum const class com.wm.lang.ns.NSWSDescriptor$Version._8_2

Source Server Detail:
IS Version : 8.2.1.0
Java Version : 1.6.0_31 (50.0)

Target Server Detail :
IS Version : 8.0.1.0
Java Version : 1.6.0_20-rev (50.0)

wM best practices suggests it is not advicible to replace/delete “Default” package.

Is this error due to reverse compatibility? How can we able to copy content from source to target server in this case?

Regards,
Jatin P

You can deploy User created assets using deployer. You cannot deploy webMethods components that have been installed by the Software AG Installer as part of a product.

Hi,

Export the package (unlock the all the services in the package) from developer (source server) and place it in replicate/inbound directory of target server. Then open target IS and install the package from package management

Or

Open the two servers in one developer and copy paste. Hope this should work. :slight_smile:

Let me know if you have any questions?

@Jatin P,

Requirement of target IS mentioned in manifest file of the package. Your package requires 8.2 IS.

Do one thing, while creating archive from IS admin[8.2] --> Package Management --> Default -> Archive --> Change the Integration Server Version and JVM Requirement .

copy the archive package from source IS[8.2]/replicate/outbound to Source IS[8.0]/replicate/inbound then install.

Although it is suggested not to make any change in default package, as it has landing admin page.

HTH.

Thanks,
Rankesh

Thanks Rankesh Kumar, Venu Ponakala and M@he$h for quick reply.

After lot of effort, we could identify that because of one of the webServiceProvider copy of package from Source Server (8.2.1) to Target Server (8.0.1) was not working.

Now we are able to copy “Default” Package (after dropping webserviceprovider which was causing issue).

Regards,
Jatin P