Unable to create a mashup API in webMethods.io API from existing APIs

product = WM API gateway IO version/fix =

I have 2 APIs in my free trial WM IO API GW:

  1. EmployeeEx
  2. ComunitiesEx

I created a new “Mashup” API ( EmployeeComunitiesMashup) from scratch, added a “Mashup” Resource, and tried to go to the API Mashups Tab to define the Mashup.
I’ve got:
"An error occurred while loading policy information. Trying to set undefined property “angle” on object: LayeredDigraphLayout()

then I tried to enable my POST resource (/create_branches_communities) and clicked “Add invoke”, chose the API Gateway API, Resource, Method and all other mandatory settings but I could not save the invoke nor the mashup.
I tried to save the API and got:
“Saving API failed.
(Routing Policies => Mashup Routing) Unable to process the PUT request for apis. An error occurred while processing the payload. Error message:
Unable to find the resource: 0”


any help would be appreciated

@Aviv.Simionovici_emp Can you cross check the resource path name and other configuration details ?

Revert back incase if it sill an issue.


Hey @Bharath_Meka1
thanks for getting back to me
it seems a bug in the wm io GW
here is the support ticket I opened https://getsupport.softwareag.com/browse/SI-510133

1 Like

Thanks for the confirmation @Aviv.Simionovici_emp

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.