Unable to connect to LDAP server

What product/components do you use and which version/fix level are you on?

MWS 10.5

Is your question related to the free trial, or to a production (customer) instance?

customer instance

What are you trying to achieve?

Please describe it in detail. Recently the password for service account user which we used to integrate MWS with LDAP has been expired and we got it reset on the application an week after that under “System > Service > Directory > Available Directory Services > LDAP_profile”. Post that MWS is restarted, but we’re still not able to connect to LDAP server

Do you get any error messages? Please provide a full error message screenshot and log file.

netscape.ldap.LDAPException: error result at netscape.ldap.LDAPConnection.checkMsg(LDAPConnection.java:4855) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at netscape.ldap.LDAPConnection.simpleBind(LDAPConnection.java:1750) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at netscape.ldap.LDAPConnection.authenticate(LDAPConnection.java:1248) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at netscape.ldap.LDAPConnection.authenticate(LDAPConnection.java:1197) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at netscape.ldap.LDAPConnection.connect(LDAPConnection.java:941) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at netscape.ldap.LDAPConnection.connect(LDAPConnection.java:889) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at netscape.ldap.LDAPConnection.connect(LDAPConnection.java:1036) ~[com.netscape.ldap_0.0.0.20120518.jar:?] at com.webmethods.portal.portlet.wm_xt_ldapdirsvc.service.LdapDirServiceHelper.connectToLDAPConnection(LdapDirServiceHelper.java:209) [wm_xt_ldapdirsvc.jar:?] at com.webmethods.portal.portlet.wm_xt_ldapdirsvc.service.LdapDirServiceHelper.access$300(LdapDirServiceHelper.java:47) [wm_xt_ldapdirsvc.jar:?] at com.webmethods.portal.portlet.wm_xt_ldapdirsvc.service.LdapDirServiceHelper$LdapDirServiceChecker.run(LdapDirServiceHelper.java:421) [wm_xt_ldapdirsvc.jar:?]

Have you installed all the latest fixes for the products and systems you are using?

Not recently

Can you perform a telnet to LDAP server from your MWS VM? If MWS cannot reach LDAP it wont be able to connect.

Telnet was disabled on servers, I tired only ping and it was success

you could try curl.
curl -v telnet://host:port

or you can try openssl:

openssl s_client -showcerts -connect host:port

yes, I was able to telnet to the server.

yes, I was able to connect to the server via telnet

Please do share the logs.

1 Like

Hi Nambi,

then it is not a mere transport layer issue but something on the LDAP connection handshake.
As Srikanth already requested provide us the logs showing the initalization (and hopefully an error message) of the LDAP connection.

Regards,
Holger