TN Element Export Exception


Need help!

While exporting TN Profile, Processing Rules, DocumentTypes etc. from TN 7.1.2, exception is thrown “[SoftwareAG][Oracle JDBC Driver]Object has been closed”.
Exception is thrown only, when we try to export, for other queries, like to find the partners, find the document type everything is working fine.
We deleted the Repository files thinking that may be because of currupt repository error is coming, but it didn’t work.
Please help.


Below is the Error Trace

ErrorMessage: ErrorDialog

Mon Apr 25 14:53:55 EDT 2011
[SoftwareAG][Oracle JDBC Driver]Object has been closed.

com.wm.ui2.UiException: java.sql.SQLException [SoftwareAG][Oracle JDBC Driver]Object has been closed. null java.sql.SQLException [SoftwareAG][Oracle JDBC Driver]Object has been closed. null null

com.wm.ui2.UiException: java.sql.SQLException [SoftwareAG][Oracle JDBC Driver]Object has been closed. at com.wm.ui2.UiException.handle( at com.wm.ui2.UiException.handle( at at at at at at$6$ at at$6.actionPerformed( at javax.swing.AbstractButton.fireActionPerformed( at javax.swing.AbstractButton$Handler.actionPerformed( at javax.swing.DefaultButtonModel.fireActionPerformed( at javax.swing.DefaultButtonModel.setPressed( at javax.swing.AbstractButton.doClick( at javax.swing.plaf.basic.BasicMenuItemUI.doClick( at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased( at javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased( at java.awt.Component.processMouseEvent( at javax.swing.JComponent.processMouseEvent( at java.awt.Component.processEvent( at java.awt.Container.processEvent( at java.awt.Component.dispatchEventImpl( at java.awt.Container.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.LightweightDispatcher.retargetMouseEvent( at java.awt.LightweightDispatcher.processMouseEvent( at java.awt.LightweightDispatcher.dispatchEvent( at java.awt.Container.dispatchEventImpl( at java.awt.Window.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.EventQueue.dispatchEvent( at java.awt.EventDispatchThread.pumpOneEventForHierarchy( at java.awt.EventDispatchThread.pumpEventsForHierarchy( at java.awt.EventDispatchThread.pumpEvents( at java.awt.EventDispatchThread.pumpEvents( at java.sql.SQLException [SoftwareAG][Oracle JDBC Driver]Object has been closed. java.sql.SQLException: [SoftwareAG][Oracle JDBC Driver]Object has been closed. at com.wm.dd.jdbc.oraclebase.BaseExceptions.createSQLException(Unknown Source) at com.wm.dd.jdbc.oraclebase.BaseExceptions.createException(Unknown Source) at com.wm.dd.jdbc.oraclebase.BaseExceptions.getException(Unknown Source) at com.wm.dd.jdbc.oraclebase.BasePreparedStatement.setString(Unknown Source) at at at at at at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at at at at at at at at at at at at at at at at at at

Make sure this folder has all the required .sql files:


After that reload WmTN package and this should work:


Thanks RMG!
Well, reloading both WmJDBCAdapter and WmTN worked for couple of exports but again it failed and threw the same exception. It is happening in almost all our environments.

Thanks & Regards,

Did you also make sure WmTN/Config folder has all the required .sql files…


Thanks for your help!
We tried the options we discussed and some more, but still the issue persist.
We raised the SR to Software AG and waiting for them to come back.


OK…Please keep the forum posted: