Error in


I am trying to configure my TN 7.1.2. I have a Oracle DB on my system and TN related tables has been created in it. I was able to create Enterprise Profile. I can also creat Partner Profiles and in the backend they are visible in the table “PARTNER” (i.e. select * from PARTNER).

But when I run a search for Partner Profiles using the TNConsole it gives me the below error :confused::

ErrorMessage: ErrorDialog TRNCONS.000000.000003 ERROR partner.PartnerQueryResult doQuery Tue Nov 15 17:59:28 GMT+05:30 2011 java.lang.ClassCastException:
com.wm.ui2.UiException: java.lang.ClassCastException: null java.lang.ClassCastException: null null

com.wm.ui2.UiException: java.lang.ClassCastException: at com.wm.ui2.UiException.handle( at com.wm.ui2.UiException.handle( at at at at$ at at java.lang.ClassCastException: java.lang.ClassCastException: at at at at at at at at at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at at at at at at at at at at at at at at at at at at

I have tried dropping and recreating TN tables using Database Component Configurator even reistalling TN but nothing has worked.

Please help.

Are you getting this error every time you query any section in TNC? or is it just intermittent?

I believe you should be OK even you get with this error:


Everytime I search this error comes. And Once I click “OK” on the error report the search stops without displaying any result.

If the error still persists…you should also contact SAG tech support for a quick turn around:

Also do you have this service scheduled?

Drop the TN SQL scripts from your database and create/recreate once again than

Use Database Configuration Tool

It seems he did tried that options aswell:

I applied some fixes to the TN and it started working fine :slight_smile:


It Sounds good :slight_smile:

Glad to hear Issue resolved…I am sure fixes are there for this:

Hi Shilpa kumar,

we are facing the same kind of issue.
what are the fixes you applied ?


Hi Venkat,

make sure you have latest Fixes for TNS (Trading Networks Server), TN_MWS (Trading Networks UI on MWS) as well as latest DC_DBS Fixes for wM Version applied.

After applying the DC_DBS-Fixes run Database Configurator and select TradingNetworks Component as “migrate” to “latest” for your TN schema.

Additional Fix which might be helpful in this case:

Which Version of wM are you running on?


Hi Holger,

we are doing this activity on wm8.0.
Trying to export from wm8.0 .