TC Windows Services

On our existing on-prem servers we have terracotta installed and it’s shown on the windows services page.

image

However we have installed TC on a new server and started it up through start-tc-server.bat but it is not appearing in the services app. How do you add the TC service in the services page?

Hi Daniel,

Have a look at the batch command file called tsa-service.bat.

It should be in
Your-SAG-home-folder\Terracotta\server\wrapper\bin

You can pass various parameters on the command line when running this. For example:
tsa-service install

Have a look at the batch file.

Wayne

2 Likes

hi wayne, thanks for your response. i ran the .bat file as suggested and got a successful response, however still not seeing the Terracotta windows service with the other SoftwareAG services.

image

Also I looked at the TC installation guide and searched for any info on the tsa-service file but didn’t find anything. Do you have any more suggestions?

Did you do a refresh in the Windows Services app?
In the app menu, click Action, then Refresh.

1 Like

Also, have a look here: Configuring the Terracotta Server to Run as a Service (softwareag.com)

This info is not always easy to find. I just did a Google search on tsa-service install windows service terracotta and found the above page.

1 Like

yes. refreshed the services, and also closed the services window and reopened, however the service did not appear.

and thanks for the link to the guide with more info. As stated in the docs, I ran the command tsa-service.bat start to see if the service was indeed installed, but it failed. not sure why (the log didn’t have any more info). maybe i’ll give the server a restart

One more thing @daniel.evans , you can look at the HTML versions of the docs by click on the HTML icon in the documentation site.

The BigMemory Max 4.4 doc/html is shown. If you have wM 10.7 then the version of BM Max used is v4.3.9 to 4.3.10. If you want to see version compatibility look here

The 4.4 doc should be close enough to what you need, but the docs web page says to contact SAG support if your version is not shown. But if you use my “trick” above, I managed to find the 4.3 BM Max docs just by doing a search :slight_smile:

Wayne

1 Like

many thanks. yes I am running v4.3.9. I did a google search for that and found the html version at
https://documentation.softwareag.com/terracotta/terracotta_439/bigmemory-max/webhelp/index.html

1 Like