Starting Adabas

I have not started my PC Adabas 6.3.2 in a couple of weeks. Went to fire it up.

I am getting a system (Windows 7 home premium) error which says

" Terminate due to Signal 11"

Has anyone ever encountered this? Any solutions?




signal 11 is just a generic error, are there any more specific messages in the log file ?

What happens when you do (from the command line) something like an ADAREP ?



Hi Wolfgang;

Sorry for the delay; dentist appointment (would rather have been here). :lol:

Here is the adarep attempt (attached)

I also tried adadba, just for the fun of it, same signal 11.

Is there some adabas or Software AG module that must be in the startup of the system? I took a lot of stuff out to speed up my boot; including all sag stuff

adarep.docx (39 KB)

Tried adabas dbid=12
Got all the settings, then the error:
Adabas Shared memory service not available.

Did you reconfigure that PC, or roll back to a previous System Restore Point ?

Anyway, try the following from a command prompt

adashm install auto
adashm start

Thank you Wolfgang.

The adashm install auto gave an error since it already existed

The adashm start worked. Adabas up and running.

This leaves unresolved why this happened in the first place.

I am reading about more about adashm and adasrv to see what I have to do to start adabas services, and to see if I can figure out what happened.

Thanks again Wolfgang

Did you probably switch the SHM service to manual start ?

Hi Wolfgang;

That is the likely source of the problem.

In my earlier post on this thread I indicated I was taking “stuff” out of the start menu and the services menu in config.sys.

One of them was probably responsible for adasrv and/or adashm.