[SOLVED] User Task Date/Time Events don't fire

Hi guys

I have a User Task with 2 Date/Time events, one that has to complete the task when a certain date is reached and one to send a reminder to a user 7 days before that date. Momentarily these conditions aren’t implemented (yet) because the two events didn’t work.

I have made the User Task a while ago and it worked but now I’m creating a new process to have a cleaner one and now the events don’t fire anymore. Below an image of the event that should complete the task, the other event is configured similarly. The only action in the example is ‘Complete Task’.

Does anyone know why these events are not being triggered because I can’t think of any reason.

If anything is still unclear or my information is incomplete, please don’t hesitate to ask.

With kind regards

How are you setting the values in date time events?
if you are using regular expression it might not work, because I had a similar requirement in 8.2 where I was using regular expressions to form the values and it didn’t work.
I had to include a field in business data to set the date time event values.

The Start Date is the Creation Date from the Task Info and then it’s supposed to wait for a certain amount of days (Days After Start Date) but I haven’t configured this yet for testing purposes.

Does this answer your question?

So In your case If event doesn’t fires after setting Days After Start Date , you can first use ‘set Task Expiry’ action on queuing of task and then use ‘Expiration Date Reached’ event to complete the task.

That could work for completing the task, but as I said in the original post, there’s a second Date/Time event which invokes a service to send a reminder. It has the same configuration except the field ‘Days After Start Date’ uses a different variable when testing is over (set to 0 at the moment).

So how could I solve this issue so both events work properly?

Sorry for being so much trouble, I’m still pretty new to Software AG :?

I just made a similar event in my task and I had the value in Days After start date as 2. What is the value that you want to set on it?
If you want to be sure whether your event is getting fired or not. Go to ‘Task Engine Administration’ and check your task’s schedule rules and find your event there, then change your event schedule to 1 minutes(for testing) and update rule.
After that you should see in your logs some thing like Firing schedule rule[/meta/default/wm_xt_portalrules/0000011194]:.

Days after Start Date should be filled in dynamically with a variable coming from another service.

And my event schedule was already set to 1 minute, I didn’t have to change anything but the event still doesn’t fire. :?

The variable giving value to the field should not be in decimals and should be a number between 0-365.
Are you able to see the logs that I mentioned? If they are coming every minute in your logs that means your events are getting fired. If not it can be a fix problem also. What version are you using?

Hey Anjini,

Thanks for all your help but a colleague of mine found the error.

In CEMM_utilsServiceStub.java the variable localEndDate was declared twice, after commenting out the second one, my events worked fine.

Kind regards