[SOLVED] Task Notification e-mail not sent

Hi everybody

I’ve made a Task Notification to let a manager of the company the application is for, know when a Task is being queued for his evaluation. But the mail is not sending, so let me give you all the settings I’ve configured.

  1. Create Task Notification

  1. Assign the user task to the corresponding role

  1. Create event to send notification (this event works, I tested by changing a value, it just doesn’t send the notification)

  1. Subscribe role to task (e-mail address for role is set: Dynamic Attribute)

What am I missing here, I’m still new to Software AG.

If anything isn’t clear please don’t hesitate to ask.

With kind regards

Hi Kevin,
Steps you performed are correct only last step (step no 4) i did not use in my project. For subscribing notification you need to login with you credentials and open the task then click on “Subscriptions”. in next page you need to click on “Subscribe” button then it will show available task. Once you select the task it will show all the available notification for that task, choose whatever you want then click on “subscribe” button and you are done.
Also you need to configure mail server on MWS as well (I hope you would have already done this step).

Hey Vikas

Thanks for replying.

Does it really matter what user you are logged in with because I have also tried subscribing a user from the role ‘Manager’ to the notification (while logged in as Administrator) but that still didn’t work.

And the Mail server is configured and tested so there shouldn’t be a problem there.

Hi Kevin,
That is ok but that is for when task is queued then it will be available to that role/group/user but if you want email to be triggered as soon as task is queued then login to MWS with the user id and look for that task then performed the steps i mentioned in my previous post.
It is very simple. What i feel is you have done all the steps but this one. Until you perform this step email notification will not trigger.

I am still able to subscribe other users to the subscription while logged in as that user, is this normal?

Hi Kevin,
It seems i am not clear in my statement. I try again. Login to MWS with user id who is having access to that task. go to the Task inbox. Just below the task inbox search result bar on the right hand side of the page you see a link call subscription. Once you click on it you will get to know what next step you have to do.

It is not possible to subscribe task for different users when login with some other user id.

Also when you say “still able to subscribe other users to the subscription while logged in as that user” where you are doing this exactly ? On which you are? what option you choose?
What feel to me is you are trying to do it on designer? If it is true then try doing it on MWS.

I did the subscription from Task List Management. And what do you mean by Task Inbox, is this the link displayed as ‘My Inbox’?

Ohh… so you are doing it as an administrator. It is fine. that you can do as well. So what is the outcome? Is it still not working?

Nope, can’t get it to work. And I just checked on the E-mail Server and sent a test mail, this worked so the problem doesn’t lie there… :s

Hi Kevin,
In the Events section Event type is ‘queued’ and in extra condition you selected as ‘all are true’ but you did not add any condition. Try adding condition then see if it is works. Other than that i do not see any other issue and this is the only difference i found in your implementation and mine.

I set ‘Email is not empty’ as a condition but it still doesn’t work. :s

Hi Kevin,
When you add condition you choose field from “Task Info” and its value from “Business Data”. Hope you have done the same.

I tried but still nothing, could I maybe see your example? Maybe that’ll help me understand.

Hi Kevin,
I’ve attached the screen shot. Please check

I have set ‘Creation Date is not empty’ from Task Info, but still nothing…

Hi Kevin,
If still it is not working then I would say better log a ticket to SAG as you performed all the necessary steps and i do not see any other thing to try.
If anyone else would like to add then it is better else i would suggest check with SAG. As to me it is working and I followed the steps we discussed in previous post.

Did you check the logs? Do you see any error there?

Found the problem!

In permissions management I had to grant the Manager Role the right permissions for the email to be sent.

Thanks again for your effort and help.

EDIT After some trial and error I have found that the ‘Tasks Administration’ permission has to be granted. Other permissions haven’t been tested individually but without that one the mail doesn’t get sent. Other permissions are configured the way I need them so no need for me to test those. Maybe there’s anyone who can complete my list? :stuck_out_tongue:


We’re having an issue that look just like yours.
What do you mean exactly by “In permissions management I had to grant the Manager Role the right permissions for the email to be sent.”

Where can I see if it’s ok for me ?

Thanks for your help.


Hey Franck

I hope this screenshot is what you need?

You just have to go to Permissions Management, select Tasks as Resource Type in the top. After that, search and put the task on which you wish to grant the rights in the column on the right hand side. After that, everything should make sense.

PS I granted all right to my role because I don’t know exactly which ones will be / won’t be necessary yet.

If you still have questions please don’t hesitate to ask.

With kind regards.

HI again,

Thanks for the reply.
I guess it was not the same issue.
I set the roles with maximum rights, but the emails are still not sent.

I was worth the try.

Thanks again.