SFTP Connection establishment fails Auth fail / authentication method

Hello,

we want to establish an SFTP connection (User+Pass) and have maintained the settings for this in the Integration Server under Settings -> SFTP.

The server alias properties are correctly maintained with alias (sftp_test), host (x.x.x.x), and port (22). In addition, the host key fingerprint has been defined.
In SFTP User Alias Properties we have maintained User/Pass and Authentication Type Password. During the connection test the following message is displayed:

[ISS.0147.9011] Test of SFTP user alias SFTP_TEST failed. Details: Auth fail
Caused by: com.wm.app.b2b.server.sftp.client.SFTPClientException: [ISS.0147.9011] Test of SFTP user alias SFTP_TEST failed. Details: Auth fail
Caused by: com.jcraft.jsch.JSchException: Auth fail

wrapper.log

INFO | jvm 6 | 2020/02/12 10:54:25 | INFO: Authentications that can continue: publickey,password
INFO | jvm 6 | 2020/02/12 10:54:25 | INFO: Next authentication method: publickey
INFO | jvm 6 | 2020/02/12 10:54:25 | INFO: Disconnecting from x.x.x.x port 22

It seems that he does not even try to log in with the password.

Tests with WinSCP and Co. work on the same machine - i.e. Firewall and Co. are not. We use Software AG Integration Server in Version 9.12.

Does anyone have any suggestions or ideas?
wrapper.log (4.79 KB)

This is a common error, I think SAG has documented knowledge base article in Empower to solve this common error. Please access Empower and find the error as the keyword.

Hi Mike Ng,

that’s good news. Unfortunately, I have not found any further helpful hints for exactly this error. Possible causes are probably:

  • Update Integration Server
  • Checking the JSCH-JAR and verifying that it is available in the correct version
  • Correction of the encryption procedures
  • Checking the setting that password is used

Please write where this general error is described and solved. Thanks a lot!

Hi Sebastian,

Please reach out to SAG Global Support by raising an incident, they’ll find the solution for you. I wouldn’t be able to tell you where since I’m no longer working with them.

Hi Sebastian,

This is a known issue, which has meanwhile been fixed.

Please check your Fix-Level with UpdateManager and apply latest available Fixes.
Hopefully you have extended maintenance aggreement activated for your wM 9.12 as standard support has ended in end of October 2019.

Regards,
Holger

Hello,

thanks for the hints - in the end it was no problem or error on the Integration Server. Instead, a parameter => sshd_config “HostbasedAuthentication yes” was missing on the SFTP.

FileZilla and Co. still worked without this parameter, but the ESB needed this parameter within the SFTP service.

Regards

Hi Bernd,

glad to hear you was able to solve it finally.

Regards,
Holger