com.jcraft.jsch.JSchException: Algorithm negotiation fail

What product/components do you use and which version/fix level?

IS 10.5

Are you using a free trial or a product with a customer license?

Customer License

What are trying to achieve? Please describe in detail.

Get SFTP connection

Do you get any error messages? Please provide a full error message screenshot and log file.

Cannot get host key from server [ftp.aes.accuweather.com]:22. Details: com.jcraft.jsch.JSchException: Algorithm negotiation fail

This is a public ftp. Ive tried with ip: 12.53.43.245 same error.

Ive tried with this SFTP Connection Failure : com.jcraft.jsch.JSchException: Algorithm negotiation fail but this is not an good answer.

What should I do?

Regards,
Jesús

Hi Jesus,

do you have applied all latest Fixes to your IS 10.5 environment?
There have been issues with the JCraft SecureChannel jars, which have been resolved by certain Fixes meanwhile.

Regards,
Holger

Hi, Holger. No, I haven’t. I’ll try with that and then I’ll notice you what happened!

Regards,
Jesús.

Hi

Can you check which user integration server running? Also what is the OS? it is windows? Typically error comes on Windows based OS, when IS tries to use NTML authentication.

What do you mean about “user integration server running”? And I’ve tried in linux and windows. This error appears in both of them.

Regards,
Jesús

User running Integration Server process.

Also, did you tried to do use any external clients like winscp to connect to sftp server?

In windows is a superuser administrator. In linux I really dont know. And yes, with WinSCP connect successfully.

Does the network protected by any proxy servers? It could be proxy that is blocking Integration Server.

No, it doesn’t. Maybe on linux but in windows in my local machine no one politicy or restriction is active. Its appears is about a Fix.
image

I’ve installed that fix but now my IS can’t start.

Error occurred while initializing server: java.lang.NoSuchMethodError: org.apache.logging.log4j.spi.LoggerContextFactory.isClassLoaderDependent()Z at org.apache.logging.slf4j.Log4jLoggerFactory.getContext(Log4jLoggerFactory.java:49) at org.apache.logging.log4j.spi.AbstractLoggerAdapter.getLogger(AbstractLoggerAdapter.java:46) at org.apache.logging.slf4j.Log4jLoggerFactory.getLogger(Log4jLoggerFactory.java:33) at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:358) at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:383) at com.maverick.ssh2.Ssh2Context.(Ssh2Context.java:58) at com.wm.app.b2b.server.sftp.client.SFTPClientCommonConfig.setMacC2S(SFTPClientCommonConfig.java:93) at com.wm.app.b2b.server.sftp.client.SFTPClientCommonConfig.loadDefaultConfiguration(SFTPClientCommonConfig.java:34) at com.wm.app.b2b.server.sftp.client.common.SFTPClientSelfMigrator.migrate(SFTPClientSelfMigrator.java:66) at com.wm.app.b2b.server.sftp.client.common.SFTPClientSelfMigrator.migrate(SFTPClientSelfMigrator.java:212) at com.wm.app.b2b.server.Server.run(Server.java:641)

Hi Jesus,

please check for the TPP_10.5_Misc_Fix3, as this contains an updated version of the JSch lib used by the SFTP feature.

Regards,
Holger

Hi, Holger.

I just installed all available fixes in SUM and then IS started.
The good news is SFTP now works! The bad news is I dont know what fix solved this!
However now SFTP works well. Thank all of you so much!

1 Like