Set attachmentbs filename in wmtntransportprimarySmtp


I would like to send an EDI message using service as an email’s attachment.
However, that service doesn’t allow me to specify the attachment’s filename in the pipeline and it appeared that the edi message could be sent as an attachment without a filename or as a message body.
Can anyone please help me with this problem?
Thank you.



Actually you cannot specify custom filename/notation when using the primarySmtp delivery method,this is the drawback in TN and i believe it is allowed in IS6.5.

Only option is making use of the smtp service and set the filename,wrap the attachement which works as expected but this is the custom way of processing as per the conditions.


I need to send a flatfile as an attachment via email.
I have used pub.client.smtp service and attached the file with the contentType Text/Plain.
After receiving the attachment via Email.Iam getting extra newline in the data.
Iam having 4 records in the flatfile.In that, first record contains 2501 characters.But the received file contains a newline after the each 990 th character .
I have uploaded the input file as well as the received file from email attachment.
Please gothrough this and help me to come out of this problem.

Thanks in advance,

Received Flatfile
received flatfile.txt (3.2 k)

Input flatfile
input file.txt (3.2 k)

Did you tried with setting contentType to application/x-wmflatfile?
and test the same.


Thanks to your response.
Yah, i have tried with ContentType as application/x-wmflatfile and text/flatfie.
But there is no updates.Are you able to recognise the extra newline in the received file?

Why it is introducing newline after 990th and 1980 th characters?
I have checked the positions in Hex Editor and TextPad.
Please Help me in this.

Above issue is solved by setting SMTP service input variable “attachments[0]/encoding” to “base64”.