How can send and receive a flatfile by AS2 EDIINT?

Now I need to send and received a customer flatfile by AS2.the file format like this:
FILBOSAH ABC_PFE DESPATCH 2010051814405700000000000000000001
DA191800057284500013124 0000301178 CarlBolin-22 34 81739 DE 1828M0482010050600000000000000000000
DA291800057280000104500013124000010WAA28222 00000000000150000000000000 PCE
TRLBOSAH ABC_PFE DESPATCH 2010051814405700000000000000000001000004000001

I have config the TN for these partner: Sender: BOSAH Receiver:ABC_PEF,and set up two test WebMethods 9.0 IS server.IS-A is for BOSAH and IS-B is for ABC_PEF.When I use the flow service: wm.EDIINT:send to send this message by AS2 from IS-A,the test IS-B server is not received anything and has any message in transaction log.
The send config like this:
Type: plain
compressed: FALSE
deliveryMethod: PrimaryHTTP
dataContentType: text/plain
requestMDN: synchronousMDN
requestSignedReceipt: FALSE

senderID id: BOSAH
idTypeDesc: EDIINT AS2

receiverID id: ABC_PFE
idTypeDesc: EDIINT AS2
Is there a solution for this problem,why we send the flatfile message but we can’t receive it?

In the EDIINT:send are you trying to send ff data as stream?

Any errors noticed in the TN with EDIINT requests message and did you receive the MDN back?

Please check the logs on both the IS’s (sender / receiver).

HTH,
RMG

Yes, given details are not sufficient to assist you, please share more info.

Thanks,

Yes,I sent the message used the typs as stream and the Sender IS server is not send successfully,the send stuts is about SendMsg:WAITMDN,the receiver IS server has not received anything.
The send side server log as below:
[3168]2016-04-19 09:42:06 CST [TNS.0000.2054I] Data for column ActivityLog.FullMessage will not fit. So, truncating it from 6474 characters to 1024 characters.
[3167]2016-04-19 09:42:06 CST [ISU.0000.9999E] com.wm.lang.flow.FlowException: sender and/or receiver unknown
[3166]2016-04-19 09:42:06 CST [TNS.0005.4027W] An exception occurred invoking a processing service for document 53u93p00agm2t0me00000061. The processing service was wm.EDIINT.rules:processMDN, and the original error message was: com.wm.lang.flow.FlowException: sender and/or receiver unknown.
[3165]2016-04-19 09:42:06 CST [ISC.0076.0007W] XMLCoder decode invalid data type: wm.EDIINT.SequenceInputStream
[3164]2016-04-19 09:42:06 CST [TNS.0000.2073I] Inserting doc 53u93p00agm2t0me00000061 into data store.
[3163]2016-04-19 09:42:06 CST [TNS.0000.2073I] Inserting doc 53u93p00agm2t0dn0000005i into data store.

For our EDIINT flat file messages we use dataContentType ‘application/octet-stream’ rather than ‘text/plain’. Perhaps that will make a difference. Also, it appears that your sending system is receiving an MDN, but sender and/or receiver can’t be determined and it may be malformed. Can you query transactions in your sending system for internalID = 53u93p00agm2t0me00000061 as that may be the MDN you are expecting. You may also want to have a look at 53u93p00agm2t0dn0000005i as it is mentioned in your log. I suggest querying all transactions in your receiving system to see if perhaps something was overlooked. Maybe the EDIINT document was received, but sender/receiver are unknown due to partner setup or other issues.

Xu,

Can you please try change the content-type to application/octet-stream and also cross check your partner setup’s between your 2 TN’s and make sure the send/receive functionality work’s as expected in your test system?

HTH,
RMG

By default, EDIINT will only handle application/xml, application/edi-x12, application/edifact.

Changing from text/plain to application/octet-stream won’t make difference.

You can create a "User Process Payload Service ", configure it at: Solutions>EDIINT>Configuration.
Read the EDI INT user guide first.

Any reason why EDIINT won’t work with “application/octet-stream” even when the document doesn’t mention all the types?

Xu, Anyways what it is the IS/EDIINT module version you are using?

HTH,
RMG

Thanks a lot,i has create the user payload service and has received the message successfully.

Glad to hear it worked for you!

Did you try change the content-type also?

HTH,
RMG

Hi,rmg,the data content type is about text/plain but delivery method has changed from PrimaryHTTP to PrimaryHTTPS.

Understood… But have you tried set content-type as application/octet-stream for send/receive flat files?

It’s ok since your new process is working just making sure to be on the same page.

HTH,
RMG