Session time out

Hi All,

How to set time out option on MWS for a specific user. I did change in mws. xml which is in “\webMethodsxx\MWS\server\default\deploy\portal.war\WEB-INF” but its still now working. Any other location and file which we have to modify to achieve it ?


Hello Ravi,

What is the default session timeout? After how many minutes does the user logs out?

Thanks Mahes for your swift response.

In my system it was 60 secs earlier, i updated it to 3000 sec but still i had the same experience.

In MWS admin page, do we have any other settings to change to keep the user session for more time.


Did you try editing in web.xml file under the same path you have mentioned earlier. (not mws.xml)

Search for

number is in sec/minutes (not sure :lol: ).

Make sure you restart the MWS. Update me back with your results.

1 Like

Yup,I did the same exaclty but I didn’t see any use of it.


Did you restart after the changes/

Yes Mahesh, I did after doing changes,but still no improvement.


:slight_smile: :slight_smile:

Are you eligible to contact SAG support. May be you can contact them.

Based on IS session time out …all the user in MWS are also time out

Below are few suggestion

  1. Check Monitoring->Integration->B2B->UserPreferences. These are setting are user specific but no golbal way or out of box solution

  2. You can see the time set in minutes under $PORTAL_HOME/server/default/deploy/portal.war/WEB-INF/web.xml and Search for the tag

below are the steps to change the value:
-Shutdown Portal server
-Open up the $PORTAL_HOME/server/default/deploy/portal.war/WEB-INF/web.xml
-Search for the tag and then change the value as required from the default value
-Restart the Portal

  1. Build custom portlet and using java script you can do this but it needs extra efforts and approvals in your organization


1 Like

Hello Ravi,

I guess you did not shut down the MWS before editing the web.xml. Is that right?