Change session timeout

Hi guys,

I would like to find a way to control the session timeout.

My goal is to increase the session timeout from 20 minutes to 60 mintues.

I’ve tried to increase the session time out in the IIS but it doesn’t seem to affect the user session. It’s still disconnect after the user is being idle for 20 mintues.

Thank in advance
Ziv

Hi Ziv,
What Applinx version are you using?
Did you tried to change the session timeout in the host properties?
Thanks,
Asaf

Hi Asaf,

I’m using Applinx ver 5.2.4.0041

The host properties dose not influence the IIS session time out, it’s look like the applinx override it when the session starts.

Now i’m trying to understand where the applinx override this session variable.

By the way, changing Session.Timeot property on session start does affects the session timeout.
:shock:

Tnx
Ziv.

Hi Ziv,
You wrote that

Hi,

  1. You wrote about three sessions IIS,ApplinX and Host but didn’t explained how to control the ApplinX session and how can i interact with it thru code.

  2. I changed the session timeout thru the configuration button in Home Directory tab of my web application properties and it didn’t effect the user connectivity.

Tnx
Ziv.

Hi again,
There are 3 timeouts that disconnect the session:

Non-activity timeout: ApplinX server disconnects the session from the host after there was no activity received from the user for the specified time. Set this timeout in the host tab of the application configuration. Note: specifying this timeout to “0” means it’s unlimited.
Web application timeout: Configured in the web application, will disconnect the web session from the ApplinX server, the ApplinX session with the host will keep on living until it will reach the non-activity timeout.
Host timeout: Configured in the host. When the host reaches its timeout the ApplinX session will be disconnected. The web application session may still be alive but you’ll get a “disconnected by host” error message with the next host-action the user will try on this session.

If you want to set the timeout to 60 min, we recommend setting the web application session to 60 min and the non-activity timeout to 60 or something slightly bigger like 61 or 65. This will make sure that you don

1 Like

Here is some more information about how to change the session timeout in the IIS:

Edit the web.config:

... ...

The session time-out refers to the number of minutes before the user session is aborted. If a large file is being uploaded it is desirable to maintain the session state. The session time-out should always be longer than the amount of time you expect uploads to take. Note that this value is only relevant if you have session state enabled.

In the example web.config file above the sessionState is set to one hour.

This was copied from - http://www.websupergoo.com/helpupload50/source/2-tech_notes/3-web.config.htm