Send messages to TN 6.1 using https-get method.

Hi All,

We have recently migrated from webM 4.6 to webM 6.1. One of our partner used to send us data using https -get method. This worked fine webM 4.6. But when the partner tries to send documents to TN 6.1 he gets access exception.
We also tried to data TN 6.1 using https-get but does not whereas on TN 4.6 we have no problems in sending data across.Has anyone experienced such a behaviour before?
Any help will be very much appreciated.

Hi Yogesh,
Pls. post the exception details are you getting?
Also, how your partner is trying to post… Java client, or using browser or Form…
As always, write us details about what platform IS is on etc…

  • Bhawesh.

“…access exception”

Would suspect that you don’t have the certificates set up correctly to correspond with the account being used. Double-check your config from 4.6 vs. 6.1.

@ raemon
We also suspected the same thing earlier so we asked the partner to send its certificates in java key store file and then tried to send data using a java client that we use to test whether the certiciates are installed properly. Using this client we were able to send data TN using https.
We also installed certificates in browser tried send data to TN ,this also worked.But we were using method =“POST” in form tag in HTML. But when we changed the method=GET we get errors and document ends up as unknown in TN.

The error partner is getting is wm.server.acess:Acess exception.
Currently we have 2 IS in cluster with 2 RI servers and TN share the same databse. The OS is AIX 5.2 and jvm we are using is 1.4.2


On further investigation we have found the following.

  • If a message is sent directly to the internal server ( running on AIX 5.2)using https get it works.
  • The same message sent through an RI running on AIX 5.2 the document is not recognised in TN even though $xmldata is present in content.
  • The same message when sent through an RI running on Windows to the Internal server running on windows or AIX 5.2 works.

Could this be anything related to OS?
Any Help will be very much appreciated.


We had also raised SR with webMethods ,They were able to reproduce the issue and now development team is looking into it…
Looks like when data is sent usingg http get via RI to internal its not received as xml so document is not recognised.

The fact that RI is involved was a huge piece of information to have ommitted. The interactions there are quite different than a direct invoke.

Let us know what tech support finds out.

Hi Raemon,

Well sorry for not mentioning RI earlier.
Neways we have a trial version of the fix from webMethods support.The fix does seem to work. We are now awaiting for the official fix to be released.
Will update the frum once we receive the fix.