select row checkbox not rendering?

Is there a reason a select row checkbox will not render? I don’t see anything on the ui after published but see it plainly in designer

In order for a row to be selectable, the table content provider must implement the ISelectableTableContentProvider interface. See:

If your table data provider doesn’t implement that interface then the select row checkbox control renders nothing.

In the simplest use case, you should use a SelectableListTableContentProvider instead of a ListTableContentProvider.

Alright - so I can’t implement with a IS directly service. This is definately a warning that should come up to specifiy why this control is allowed to be implemented but doesn’t work/rendered without warning.

Instead I put a BasicUpdateTable off of the Output.results but still running into empty column for basic SelectRowCheckBox - and still not getting resulting checkbox - what else could be the problem?

I agree that there should be a warning displayed for your condition. I’ve filed a new bug report to get this looked at.

I’d double check your bindings and if you are still having issues, I’d suggest opening up an SR.

Thanks - I finally ripped it all out and re-did it and it worked. I don’t know if there is something table/code wise that is getting cached because it worked after completely deleteing the service and tables.