Schedulers disabled when WMTN pkg was reloaded after TN import

Hi Team,

We had reloaded the wmTN package after importing the TN extract in production.

Due to that, we have noticed that the Schedulers - for all the queues got disabled, thus causing delay in delivering the files. We had to manually enable all the schedulers again.
Can you please check this and see how this can be handled in future.

Nanduru – Even I came across this problem in wm8 version, not sure why. Which version you are using ?



Nanduru – Did you get a chance to check all the error/server logs closely that particular day/time when schedulers got disabled ? Probably with this information we may some clue to light our way to further proceed.


Schedulers were disabled once WMTN pkg is reloaded

Oh,we have less information with this, let’s see what other comments.


IS will suspend schedule jobs if the job is calling a service that doesn’t exists.
When you reload TN package, if the tn delivery job is just executing, since the services will be unloaded before reloaded, it will trigger this behavior.
You can just simply "Pause Scheduler " on the scheduler page before reloading TN package. Then resume it afterwards.

Yes that’s the expected behavior when the package is reloaded or particular service not exist run-time and you will also see the errors in the event of the job runs.