SAP Adapter: ERROR max no of 202 conversations exceeded

Good morning everyone,

we are implementing the Integration Server with the SAP Adapter. At night SAP sends 15000 IDOCs that generate an error on the ESB:



[ART.118.5053] Adapter Runtime (Connection): Unable to get a connection to resource Connection:connNode_SAPConnection200.
[SAP.102.9000] JCo error: (102) JCO_ERROR_COMMUNICATION - Connect to SAP gateway failed
Connection parameters: TYPE=A DEST=SAPConnection200 ASHOST=XXX.XXX.XXX.XXX SYSNR=00 PCS=1
LOCATION CPIC (TCP/IP) on local host with Unicode
ERROR max no of 202 conversations exceeded
TIME Tue Feb 04 01:56:53 2020
RELEASE 721
COMPONENT CPIC (TCP/IP) with Unicode
VERSION 3
RC 466
MODULE r3cpic.c
LINE 14869
COUNTER 1

This error blocks all communication to and from SAP, and the only solution I found so far is to restart the ESB server.

Can somebody help me?

The SAP-Adapter version is: 10.1.0.0.1008
The J-Co version is: 3.0.19 (2018-12-03)
The WebMethods version is: 10.3.0.0

This is a pretty common error in SAP Adapter, you may check the resolution as part of the knowledgebase article in Empower. Some SAP property configuration needs to be done on the RFC client side.

Hi Diego,

please get in contact with your SAP Basis Administrator and ask them to increase the number of allowed connections for this Program-Id.

Additionally check your version of the JCo API.

There is a newer version for 3.0.x available on SAP Marketplace as well as 3.1.x version.
Please check for availability of Fixes for SAP Adapter with UpdateManager.

Regards,
Holger

WmSAP uses the SAP JCo library for all RFC connectivity, and JCo limits the max number of concurrently open RFC (internally: CPIC) connections to a default of usually 202 (depending on the OS and environment).

The root cause is that more of 202 connections were tried to be opened at the same time. This is an arbitrary limit of the SAP JCo library which can be changed.

If this error comes up then definitely more than 202 connections were tried to be opened at once. The customer could either increase the jco.cpic_maxconv value, or decrease the max pool size values of their RFC connections, or decrease the RFC connection time-out value (see WmSAP UG for mor details).

(Please note that RFC connections also need ‘invisible’ internal metadata connections to lookup the SAP metadata, which are also CPIC connections)

The proper jco.cpic_maxconv is usually different from environment to environement and depends on the individual needs of an application. Cx may try to increase the value to e. g. 400 for a first test.

Please note that, as already mentioned by Mike, there is also a KB note on this topic.

thank you all for your answers.

Could you give me more information please?

the SAP Basis Administrator told me he’s already increased the number of connections. I have downloaded the new versions for sapjidoc and sapjco, when the server restart is done I will try to upload the new versions.
I also downloaded the updater, but when I click on “Fix Content…” an error message appears: “Cannot show fix content due to insufficient RAM memory. Increase the Java memory and try again”.

How can i increase the value?

Thank you,
Diego

Hi Diego,

In this case you can try to modify the Start-Skript for UpdateManager after you have installed it.

Add “-Xmx 2048” to the two lines where the UpdateManager is started via jvm.
Increase the value if the OutOfMemory is still occuring.

Maximum value is depending on the pysical memory available in the box and the memory being used by other services and programs.

Remember to shutdown and restart the IntegrationServer after updating the jco libs.

Regards,
Holger

Hi Holger, thank you.

can you tell me where I can find the start-script file? I found only a “restart-script” with this content:


#Tue Feb 04 14:48:41 CET 2020
combooption=Fix Management
empowerUser=XXXXXXX
scriptConfirm=N
END_RESTART_UPDATE_SCRIPT=true
action=View available fixes
scriptFile=
empowerPwd=XXXX
installDir=C\:\\SoftwareAG
diagnoserKey=
createEmpowerImage=N
imageFile=

do you know something about the jco.cpic_maxconv value?

Thank you,
Diego

Hi Diego,

go to the installation directory where you have installed UpdateManager and then to the bin directory.

There should be two BAT files for Windows or two SH files for Unix.
Inside of these files you will find the jvm invocation to start the UpdateManager.

Add the memory parameter to these lines and save the file.

For the JCo Parameter:
This is a command line switch for the IS.
See KB Article "1791335 : webMethods SAP Adapter - Error “max no of 202 conversations exceeded’ seen - webMethods SAP Adapter [WSP]” for Details.
You can find this article by searching for “sap maxconv” in the Empower page.

Regards,
Holger

Thank you, today we will try to insert the 2 line for the UpdateManager.
We also add the line for the problem of 202 conversations, and it’s work.

Diego

Hi Holger,
i’ve followed your precious advice to edit the maximum allocated heap memory thus it seems like it’s not helping. The problem is persisting.
In order to avoid misunderstandings, i’d like to explain what i did:
As soon as i approched the file, I noticed that, by default, it invokes environmental var %JAVA_OPTIONS% (which were already set to be -Xms2048 and -Xmx4096).
So at first i tried to change those values from system environment variables management, it didn’t work.
So instead i directly changed %JAVA_OPTIONS% to “-Xms2048m -Xmx4096m” but it’s not working either.
In the end i tried to run the .jar package directly from the console allocating memory on the go:


java -Xms4096m -Xmx8192m -jar .\SUMlauncher.jar

Didn’t work either.
At last i checked SAGUpdateManager launcher logs trying to understand how this message is getting generated and i noticed this:


Array with SUM start command arguments: [C:\SAGUpdateManager\jvm\jre\bin\java, -DsumProc="com.softwareag.plm.sum.client.launcher.steps.impl.SetCommandForStart2020-01-14T21:20:07.733", -classpath, C:\SAGUpdateManager\UpdateManager\repository\plugins\org.eclipse.osgi_3.11.1.v20160708-1632.jar;C:\SAGUpdateManager\UpdateManager\bootstrap\classes, [b]-Xmx1024m[/b], -DSUM.HOME=C:\SAGUpdateManager\UpdateManager, -Dosgi.install.area=C:\SAGUpdateManager\UpdateManager\profile, -Dosgi.instance.area=C:\SAGUpdateManager\UpdateManager\profile, -Djava.io.tmpdir=C:\SAGUpdateManager\UpdateManager\tmp, -Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient, com.softwareag.fixinstall.bootstrap.BootstrapClass, -debug, -configuration, C:\SAGUpdateManager\UpdateManager\profile\configuration, -application, com.softwareag.fixinstall.guiinstaller.application]

May it be the point of the problem? if it is, am i looking into the wrong direction?
In order to make things clearer i’m attaching the modified files based on your hint.
Thanks again!

UpdateManagerGUI.bat (1.67 KB)
UpdateManagerCMD.bat (1.23 KB)

Hi Diego,

as the launcher log points to -Xmx1024m, this seems to be defined in one of the config files.

Unfortunately I was not able to determine which one.
I have checked my local SUM 11.0 Installation but in none of the files was a property JAVA_OPTIONS defined.

Regards,
Holger

Hi Diego,

in UpdateManagerGUI.bat you missed one line to add the memory parameters to.
This one has 3 lines of jvm invocations.

Additionally this file looks different than mine.

Which version of SUM are you using? I have SUM 11 already.

Regards,
Holger

Good morning Holgen,
I’ve somehow managed to get things to work. It keeps acting weird and i’m going to explain how but firstly my SUM version is 10.3.
Yesterday, as soon as i uploaded files for a feedback, i noticed the third final invoke of jvm in UpdateMangerGUI. That did not really solve the problem, BUT, launching the sumlauncher this way from prompt:


java -Xms4096m -Xmx8192m -jar C:\SAGUpdateManager\bin\SUMlauncher.jar

it still keeps acting weird, for example, if i directly go to the fix needed and just download it, it goes smoothly, but if i pick more than one fix to download it prompts the usual message to pick one fix only and, after this, whatever fix i pick, the same error about RAM pops up again. Closing and starting the client again, from the prompt, solves the problem.

Hi Diego,

in this case you might want to consider opening an Incident with SAG to sort this out.

Sounds strange to me.

Regards,
Holger

Hi Diego Vescovi,

The UpdateManager issue is separate issue, suggestion from Juergen will work to resolve the SAP error issue. Please refer to the kb article and then close this thread.