org.apache.axis2.AxisFault: Resetting to invalid mark

I’m running a Java XML RPC Server via EntireX.jar 8.2 and get the following error if I submit a query via webservice:

XML Tester Error: Broker Error 2000 0079: Transport error. Caused by:org.apache.axis2.AxisFault: Resetting to invalid mark

Broker Error 2000 0079: Transport error. Caused by:org.apache.axis2.AxisFault: Resetting to invalid mark

I can replicate it on a UNIX(server) and Windows(local) environment. I’ve increased the MAX-MESSAGE-LENGTH to 400Mb and still get the exact same error. I have a webservice which has about 10 fields in the response. I can return about 3600 records fine, but as soon as I try 3700 it returns this error. Another more complicated webservice which contains arrays within the response it returns the same error and the number of records it should return is about 1700.

I’m testing it via the Quick tester within the Software AG designer. My generated NATURAL stubs gave this error so I decided to bypass the Natural stubs and test it directly via the quick tester.


Can you reproduce this error also with the latest 8.2.2 hot fix 53 for the entirex.jar, available on Empower?

If yes, please open a support request.

Hi Rolf,

Thank you for the information. I only found a hotfix_52 for the eclipse environment, but via our local SAG representative got hold of hotfix_53 of the EntireX.jar file and I tested it and it gives me the same error.

We have now send the information to our local SAG office as well for a response as this is basically halting us from continueing using the XML Server for volume data.

Our local SAG guys will try to reproduce the error and log a call.

I’ve tried to log a support request for another problem we have and the support centre is - to be frank - rubbish. They keep on asking the same exact questions over and over altho I provide them with detailed information of the error and the questions is answered in the detailed description document. I eventually after about 6 months of answering the same questions sending them the same detailed document over and over again just got fed up and I refered the issue to my management. We still don’t have an answer to that issue. This is mainly the reason I had put the error on this forum first.


I somehow oversight that the error happens deep down in Axis. Since the EntireX runtime uses the Software AG Web Services Stack you might also give the latest fix for the WSStack a try. Or wait until the support gets the data.

Regarding the “other” issue, is this the one about alias names and generated Natural stubs?

Is the WSStack on Empower?

Yes the other issue was the stubs issue. I didn’t want to go into to much detail to give the full context of the issue of their perspective and ours. We were send a spesific update HOTFIX as to help us, but this fix made things even worse then the HOTFIX before that.
I’m now basically using the second last Stellenbosch spesific hotfix as this works the best and then I just change the wrongly generated method call in the Natural STUB by hand. The last fix was suppose to fix the Natural STUB issue, but it then buggered the IDL generator with regards to the ALIAS.

After I mentioned this to the support team they basically become annoid with me after we put pressure via SAG SA management on them. The original user docs explained correctly how the process should work, but the software didn’t work as the docs said. I mentioned that to them on numerous occations as well as in my detailed report and they basically put a message or something into the user documentation. They kept on telling me it is because if backward compatiblilty, but I differ from them as it was not working from the start before they made the changes which controdicted their statement. I wish I made coppies of the original screens.

They said that the fix will be available in the next release of the software. I have the latest eclipse and must still check if things have indeed improved or not.

Hi Werner,

yes, the Web Services Stack fixes are available on Empower.

Edit: although you can see the fixes for 822 in Empower, you cannot download it from Empower. The fix is available via the Software AG Update Manager.

Hi Rolf,

Thank you very much. I had to install the UPDATE Manager, because the fix can’t be downloaded from the website. I didn’t know the update manager is a seperate tool you need to install with the designer…

Anyway I’m busy doing updates as we speak…and then will continue my testing…


Okay I tried the download manager to get the fix…doesn’t work. It gives me an error “error in ProcessFix”. If tried now building an image file, still no luck…

It seems the fix has issues… So I need to get the the file from somewhere…to download directly

the following error in the windows command window displayes with the downloading of the fix:

C:\Users\werner\Documents\SoftwareAG Installs\mirror.xml:1: Messages while mirro
ring artifact descriptors.
Unable to read repository at

this is so frustrating - I’ve been trying now for the 10th time… this is rediculous… does SAG test their stuff before releasing it to the public…!!!

Hi Rolf,

I managed now to install the WSSTACK fix, this morning everything installed perfectly. And the good news is is that the error seems to be fixed at least on my windows machine.

So now I must figure out how to update the Unix machine. I suppose on empower there will be docs on how to do that.

Thank you so much for your help so far
I really appreciate it.


Hi Werner,

good to hear that you finally made progress.

The Update Manager is also available for Unix.