EntireX Webservices Wrapper

Hello,

I’m trying to publish Natural Subprograms as Webservices using xmlrt servlet. I’ve configured RPC servers on the Natural side, I can get IDL’s generate corresponding Webservices using the eclipse plugin, … but when I try to call my Webservices I have the following error :


<SOAP-ENV:Fault>
  <faultcode>Client</faultcode> 
  <faultstring>Broker Error 1014 1696: NATUARL RPC Server returns: CBRNNPAY 9999 NAT1696 Logon to library MTI for user ID *UNKNOWN denied, reason 2.</faultstring> 
  <faultactor>http://89.10.12.210/XMLAdapter</faultactor> 
</SOAP-ENV:Fault>

My xml-init.xml looks like this :


<?xml version="1.0" encoding="UTF-8"?>
<EntireXXMLInit Version="7.2.1" xmlns="http://namespaces.softwareag.com/entirex/xml/rt">
	<xmms>
		<exx-xmm 
			exx-use-security="false"
			exx-natural-security="true"
			exx-natural-library="MTI"
			exx-rpc-userID="OMEGA" 
			exx-rpc-password="OMEGA" 
			exx-userID="OMEGA" 
			exx-password="OMEGA"
			>/entirex/WebContent/MTI.xmm</exx-xmm>
	</xmms>
</EntireXXMLInit>

I’m sure i’m missing something. Do you have an idea where to search to solve this issue?

Thanks for your help.

G.

Hi Guillaume
I seem to remember something about an additional (none related) parameter that had to be specified as well - I thing it was encryption.
The passage below from the exx documentation suggests the same
Finn

The HTTP parameter exx-use-security (true, false) is responsible for EntireX Security. With exx-encryption-level (0,1,2), you have to set the Encyption Level (required).

Hi Finn,

I have done the test, but unfortunately, it doesn’t work, same response, “Logon to library MTI for user ID *UNKNOWN denied”.
I don’t know why the user ID transmitted is *UNKNOWN.

The user specified in xml-init.xml seems to be unusefull !
Any other idea ?

Regards

Hi Guillaume,
I found an entry in Servline24 describing the problem I had.
Have you specified it like this ?
Finn

Add exx-encryption-level=“0” and add exx-use-codepage=“true” to the xml-init.xml.

The entry also said that this should no longer be necessary from exx733.

Hi Finn,

I’ve made the test, but with nosuccess. Here is my xml-init.xml file. I have verified that this file is really used, and it is.

<?xml version="1.0" encoding="UTF-8"?>
<EntireXXMLInit Version="7.2.1" xmlns="http://namespaces.softwareag.com/entirex/xml/rt">
	<xmms>

		<exx-xmm 
			exx-natural-library="MTI" 
			exx-natural-security="true"
			exx-encryption-level="0" 
			exx-use-codepage="true"
			exx-password="OMEGA" 
			exx-rpc-password="OMEGA" 
			exx-rpc-userID="OMEGA" 
			exx-use-security="false" 
			exx-userID="OMEGA"
			exx-brokerID="brokerdev.sgbt.lu:1977"
			exx-service="RPC/MTIIDL01/CALLNAT"
		>/services/CBRNNPAY.xmm</exx-xmm>

   </xmms>
</EntireXXMLInit>

The user OMEGA is well defined on the mainframe side. I can use this user to connect to the RPC environment in the workbench to extract IDLs. So I think this user and RPC is well configured.

Looking at the logs on the server, I think that the user is not transmitted correctly to the Broker.

Thanks for your help

G.
errorlog.txt (23.3 KB)

Hi Guillaume,
Have you experimented with removing the line:
exx-use-security=“false” ?

  • or setting it to “true” ?

WHat I did when I encountered this at a customer was to try to trace the http call using an tool called “TPCtrace” from http://www.pocketsoap.com/tcptrace/

Using that we discovered the diff between a call from the exx tester tool in exx and which parameters where specified in the xml-init.xml file.
Finn
PS have you considered upgrading the extirex.jar file to exx733 ?

Hi Finn,

Thanks to your input I found the problem. Upgrading the entirex.jar within my webapp solved the issue.

The problem is that on the distribution CD of the Entirex Communicator 7.3.2 for Windows, the entirex.war included in C:\Program Files\Software AG\EntireX\Webapps use the entirex.jar version 7.2.1.

Thanks for your very usefull help !

Regards

G.