Runtime Error

I am pretty new here, hope someone could help me out. When i try to run a program, it gives me an error NAT0082 Invalid command, or Object CMON <My file name) does not exit in library. Does this relate to Manager Security, if so…how to fix it please?


This is a Natural error message, as indicated by the NAT0082, and is not related to Adabas. It would have been better to post your question in the Natural for Mainframes forum. Also, there is no Manager Security and it is unlikely that your error is the result of Natural Security settings.

It appears that you are attempting to execute a Natural program called CMON. Natural cannot find an executable object of that name. The simple solution is to CATALOG the source code module to create an executable for it.

A more complex solution: To execute the CMON object, it must be found in your current Natural library or in a library defined in your STEPLIB chain. Your tech lead or Natural administrator can help you check that.

Thanks Ralph,
I am very new to Natural (self-study), I downloaded a trial version, install on my laptop and try to run some programs as I read along. I know my file is in Natual-Libraries folder. I created a subfolder and leave it there. Not sure why it doesn’t work for me.

Thanks anyway.

Welcome to the Natural community!

Here are a few things to try.

  • Open your source module, CMON. (This must be done in Natural Studio; you cannot maintain any Natural object using 3rd-party tools directly in the Natural directory structures.) In the Studio title bar you should see [CMON [library-name] module-type], and the module type should be Program.
  • Rather than execute the program, try to run it. This can be invoked 3 ways:
    . enter RUN in the command box
    . ctrl-r
    . press the RUN icon in the Object toolbar

Are you using NaturalONE - started via the Software AG Designer and eclipse based ?

If yes you need to save the program and then ‘compile’ it. Click the symbol with the ‘PC and the two yellow arrows’ in the navigator view. You might also set the automatic build ON (windows>preferences>Software AG>Natural and tick there the ´Build Natural projects automatically`. After saving it will be compiled automatically.