Repository losing transformations

I am using ApplinX v 5.24 on Windows Werver 2003. When I add transformations to the repository and save them they appear to be saving correctly. When I shut down the admin interface and go back in, the transformations are still present. However, when I restart the ApplinX service in the services control panel and then check for the transformations; they disappear!! All this is done on the Windows 2003 Server.

When I connect to the same server instance of ApplinX from a Windows XP machine and add a transformation it is saved correctly i.e. it does not disappear after restarting the ApplinX service on the server.

I have tried using a file as a repository with the same result. The repository is currently in SQL Server 2008 Express.

Is there somewhere that I can log what is going on when I save a transformation? The Windows ODBC trace logging does not log any events and the ApplinX log does not either.

Your assisstance is appreciated.

Hi Yuben,
I’ve tried reproducing with no luck.
The problem sound strange but issues of entities disappearing from the DB is very serious so any help you can supply on how to reproduce it would be much appreciated.

  1. Is the problem reproduced with different DB?
  2. Can you reproduce it with SQL server 2005?
  3. When you wrote that you tried to use a file as a repository - are you talking about GXZ? can you explain what are the steps you did?
  4. I happen for every transformation you are trying to create and save or for specific transformation?

Waiting for you replay,

Hi Asaf

Thanks for your reply.

It might be SQL Server 2008 that is the issue. I have tried an Access database and it works fine. When I have some time I will check the SQL 2008 logs to find out why the problem is occurring. I suspect it is some sort of incompatibilty with the JDBC/ODBC bridge and SQL Server 2008. I will let you know the results of my testing.

In answer to your question about the file repository - there is an option on the application properties - repository tab, to use an import file as the repository.