General Availability (GA) of webMethods ApplinX 9.9

Dear ApplinX users

I’m happy to announce the General Availability (GA) of webMethods ApplinX 9.9 as a part of webMethods Suite 9.9 2015OCT release.
The GA release is available for all ApplinX customers.

Here are the new features in this release:

  • Comparing ApplinX Applications
    With the new function Compare Application… you can compare two ApplinX applications, typically two versions of the same application.
    In terms of application lifecycle management, being able to compare two different versions means you can perform impact analysis before deploying a new application version.
    For example, before deploying to your production environment you can compare your current test application with the production version to see what changes were made, make sure the new application version is complete and that all the included changes were intentional.
    For further detailed information refer to Comparing Applications under Developing an ApplinX Application in the product documentation.
  • Invoking a Procedure, Using REST
    In addition to SOAP, ApplinX web services can now be invoked using REST.
    From the Procedure Group Entity Editor, select a procedure and choose the new option Copy REST URL to clipboard.
    See Invoking a Procedure, Using REST API under Web Services in section Designing and Developing an Application.
  • Upgrade to Tomcat Server 8.0
    The ApplinX internal Tomcat server is now version 8.0.
  • Improved Performance for Large Send Sections
    Performance for large send sections (for example Natural Data Transfer upload or the AS/400 save state feature) has been improved.
  • Enter Key Recognition
    A distinction is now made between the two Enter keys (on numeric keypad and the main keyboard).
    The following line has been added to the keyboardMapping.XML" configuration file:

    For further detailed information refer to Keyboard Mapping under Client Side (JavaScript) in the ApplinX Development API References.
  • Improved Usability in Flow Mappers
    Links now show source / target index expressions (if any exist).
    Double clicking anywhere on a link opens the link properties dialog (if the link can have properties). If a target index exists, “Append” is now off by default.

This version is now available for download from Empower under the name ApplinX (v9.9 SP0)

Best regards,
Gadi Benedek
ApplinX R&D Product Manager

Documentation reads:
ApplinX for JSP Web Application

Developer’s station:
JDK 1.7
Apache Tomcat 5.5/6.0/7.0
JSP IDE - it is recommended to use Software AG Designer 9 (based on Eclipse 4.4)

Server:
JDK 1.7
One of the following application servers:
Apache Tomcat 5.5/6.0/7.0
IBM WebSphere 8.5
WebLogic 10.3/11g
JBoss 5.0

I was under the impression that we could use JDK 1.8 and Apache Tomcat 8.0.

Tomcat 8.0 can also be used; we’ll update the documentation accordingly.
With version 9.9 you can use JDK 1.8 for your runtime environment.
Starting with our next version, APX9.10, you will need to move to JDK 1.8.

Regards,
Gadi

Hi Gadi,

We are currently using Applinx9.5 with java1.7. Since the support for 9.5 is being stopped in Sep2016, we are planning to upgrade to Applinx9.9 with same java1.7 version. I am reading with Applinx9.10, you are no longer supporting java1.7 version and supports only java1.8. So trying to understand the pros & cons of directly upgrading to Applinx9.10 instead of Applinx9.9? Could you please answer the below queries:

  1. Is Applinx9.10 avaiable to download & use? If so, what are the system requirements?
  2. What is the End of Support for Applinx9.10?
  3. If we upgrade from 9.5 to 9.10, current request/responses will work or do we need to generate new requests/respones?
  4. If we upgrade from 9.5 to 9.10, do we also need to upgrade our java application (currently on jdk1.7_80) running on weblogic11g?

Thanks,
Janardhan

Hi Janardhan,

Since you’re planning on migrating out of 9.5 anyway, and if you don’t have any restrictions using Java 1.8, I think that moving to 9.10 would be better. The migration effort should be the same no matter if you choose 9.9 or 9.10 so since 9.10 will be supported for longer time it makes sense to use it.

  1. Is Applinx9.10 available to download & use? If so, what are the system requirements?
    >>> 9.10 should be available for download, it was officially released this week.
    System requirements can be found here:
    Hardware: http://techcommunity.softwareag.com/ecosystem/documentation/webmethods/wmsuites/wmsuite9-10/ApplinX/9-10_ApplinX/getstarted/RecHardware.htm
    Software: http://techcommunity.softwareag.com/ecosystem/documentation/webmethods/wmsuites/wmsuite9-10/ApplinX/9-10_ApplinX/getstarted/Software.htm

  2. What is the End of Support for Applinx9.10?
    >>> I’m not sure, usually its 3 years from release date. As it was just released I can tell you that for now it’s the version that’s going to be supported for the longest time out of all currently supported versions ?

  3. If we upgrade from 9.5 to 9.10, current request/responses will work or do we need to generate new requests/response?
    >>> Everything should continue to work as it was.

  4. If we upgrade from 9.5 to 9.10, do we also need to upgrade our java application (currently on jdk1.7_80) running on weblogic11g?
    >>> Yes. Web applications should be upgraded to the same version of the server’s and as mentioned you’ll need to use jdk1.8. Please note that we didn’t test with weblogic 11g. We tested with weblogic 12.1.3.

Hope this helps, let me know if further clarifications are needed.

Regards,
Gadi

Hi Gadi,

I have a quick question.

As of now we are using emulation applications by opening window.open by passing required params to the emulation app as query strings. Please see below:

var url=“https://servername:port/emulation_template_fdr/index.jsp?arg1=”+arg1+"&arg2="+arg2+"&arg3="+arg3+"&arg4="+arg4+"&arg5="+arg5;
window.open(url,"_blank","");

Since the args that we pass is a PCI sensitive data, we have been asked to pass the args to emulation app using post method so that args will not be displayed in browser. Would the below same code work for post parameters also? We have changed our code to post method, however we are not seeing the args are being passed using the below code. Could you please help?

String logonId = getTagsAccesor().getTagContent(“logonid”);
String password = getTagsAccesor().getTagContent(“password”);
String casn = getTagsAccesor().getTagContent(“casn”);
String fdsn = getTagsAccesor().getTagContent(“fdsn”);
String id="cd1 "+getTagsAccesor().getTagContent(“cardholderid”);

Using “getTagsAccesor().getTagContent()” should give you access to all fields shown in the screen, if you put these parameters properly inside hidden fields than you should be able to access them.
You wrote only one side of the code, which seems to be ok, but we need to see both sides to say anything about this.
I suggest to open a support call with Global Support and they will be happy to assist.

Regards,
Gadi

Hi Gadi,

Could you please provide your inputs on the below queries:

  1. Is Applinx9.9 supports jdk1.7_80 ? or we have to compulsorily use jdk1.8 and above?

Hope Applinx9.9 supports all builds in jdk1.7. If it doesn’t support, please provide the min & max build version under jdk1.7

Ex: JDK1.7_XX

Thanks,
Janardhan

APX 9.9 supports jdk1.7_80.
With APX9.9 you can use either jdk1.7 OR jdk1.8.
Starting with APX9.10 you will need to use jdk1.8.

Hi Gadi,

We imported gxars with entities from current ApplinX9.5 version (which is running on jdk1.7_25 solaris machine) to new ApplinX9.9 version (which is running on jdk1.7_80 windows machine). After importing gxar’s successfully, i am getting null pointer exceptions in my java application. This is due to most of the Input/Output field mappings are missed. I tried to update the field level mappings, but they are not getting saved after i click on Save in Software AG Designer ApplinX IDE. Could you please tell me the solution to copy gxars/gxz with out missing mappings or any other solution to save the mappings after i click on Save button?

Thanks,
Janardhan

fyi.

After we moved the gxars to the new environment, the application/module is read-only by default. I removed the read-only lock and tried saving the mappings, but still…the mappings are not being saved. Please help me in this matter.

Thanks,
Janardhan

when you have a new question, please open a new thread.

Use the settings to move your gxar (which is read-only) to a database repository.

[Apologies for this reply - it only applies pre v9.8]

Hi Kelly, next time i will start a new thread.

I do not see settings option in Designer tool. i took the raw gxars from 9.5 version and imported them in Designer tool using “Import/Replace Application”. After imported successfully, the application is read-only by default. I clicked on Repository inside application and unlocked the Read-only to make changes as i found that some of the mappings have been missed. But when i try to map them and Save, they are not saving. This is where i stuck. Please help me.

Thanks,
Janu

Check the server log and Designer’s Eclipse error log to see if any errors are recorded there. If that doesn’t point to a solution, please open a support request and provide gxar(s), server log and screenshots of the steps you have taken, along with the usual version information - what ApplinX, Designer version and fix level you are on, what operating system(s) ApplinX and Designer are running on.