Remote SoftwareAG repositories not working for CCE 9.12

Hello All,

I have configured MATER repositories in CCE 9.12 by command:

cc exec templates composite apply repos "empower.username=<username>" "empower.password=<password>"

I have also configured PROXY setup in SPM.

But when i try to access repository there is error message below:

Message: Unable to load remote repository The server returned null result.

Description: The attempt to load to the specified remote repository failed.
Action: Ensure that the correct repository metadata is provided and try again.

Strange for me is that it worked some time ago, but now it does not work (even I remove repositories and configure them again).

Any ideas, please?


It started to work from yesterday. :slight_smile:

Hi Ladislav,

did you make any changes or did it start working just from one day to another?

If you have made changes, can you describe them here so that next members having the same or similar issue can try these?


Hi Holger,

finally i did not make changes. I was just playing with that. Restarted it many times, removed PROXY and setup it again. But initial and final setup is exactly same. Maybe is possible that issue was on repository side and someone fixed it at time when I was playing? :smiley:

I will describe what I exactly did step by step, but not sure if this makes repository working:

  1. disconnect from company network and connect directly to internet (not to be behind proxy)
  2. remove proxy setup from SPM
  3. restart SPM
  4. repository started work
  5. connect back to company network (behind proxy)
  6. setup proxy in SPM
  7. restart SPM
  8. repository still working


Hi Ladislav,

thanks for outlining the steps.

You are right, the issue coud have been on the remote side (or in the network) and after this was fixed the connection was available agan.