release char issue before/after EDI batching

Hi, In one of our integration EDIFACT data mapped from Idoc is posted to TN for batching and then batched doc (envelope) is delivered to the partner through FTP.

In one of the case, we found out the data from end system came with single quote at end, which was mapped to one of the EDIFACT segments last field. Issue is we were also using the Single quote as a segment delimiter. We have specified the release character is ^ before posting to TN in convertToString service and it was working when the EDIFACT messgae is first posted to TN (before batching).

Data Before batching: << After string XYZ we had a spl character as single quote which was now prefixed with release character ^ and two single quotes - first single quote for data from end system and other quote is a segment delimiter for FTX segment >>

FTX+LIN+++H20091005:XYZ^’‘MOA+79:469.95:EUR:4’MOA+98:469.95:EUR:4’

Whereas after batching on the EDIFACT envelope posted back to TN has only single quote after the release character:

FTX+LIN+++H20091005:XYZ^‘MOA+79:469.95:EUR:4’MOA+98:469.95:EUR:4’

On the batch queue also the delimiter-release character was set as ^.

Do I have to correct my configuration somewhere or do we have any known fixes for this issue?

We were using 7.1.2 IS and EDI version is 6.5.2 with fix Fix_11.

Can you try using widely used escape mechanism release character like[B] [/b] (backward slash) also set it in partner TPA and pass it in convertToString and/or remaining configuration seems OK.

HTH,
RMG

RMG, I tried with release character option which haven`t helped. We have raised SR with SAG team. They were trying to replicate the issue in their env and if it exists they have promised to provide the fix for this issue. Will update the forum once we got some updates from SAG team.

May be fix is required for it…Please let us know the outcome…thanks for the update!

HTH,
RMg

Hi,

EDI batching is failed to processes 850 some times for newly added customers,But reprocessing the transaction is working

I have crossed checked with all the profiles created earlier and latest.Every thing seems to similar,But not sure why is this happening and your help is really appericated

Thanks
Sai

I am not sure what is your batch setup…

Give us more info and the error you are seeing:

We are having problem for one of the client in production.

EDI Outbound Frame work is designed in following way

–>Document are received into Queue through processing rule
–>EDI Batching will process those documents and places them in new Queue
–>Document from new Queue send them to different client through sterling VAN

It seems that some of the PO’s are not processed by EDI Batching for newly added vendors and reprocessing is working for most of them. Partner profile and TPA seems to same as old vendors

Please see error below

[ATTACH=CONFIG]892[/ATTACH]

Error says partners are inactive, but partners are active

We tried to check number of transaction processed in failure time and they were less than 25

Please suggest me for fixing this issue

Your help is really appreciated

Thanks
Sai.
ss.bmp (21.7 KB)
111.jpg

On the EDIBatch queue setup is the sender/receiver ids (for new TP’s) setup?

Before moving to Prod did you tested adding new TP’s in the batching in QA?

Are you sure TP’s are Active (Enabled) in TNC?

HTH,
RMg

Please find the answers in red

Thanks
sai

OK not sure what else could be the reason here.

How are you adding new TP’s to your batching? In the generic rule or new batch queues setup?

But better check with SAG support in the mean time:

HTH,
RMG