Reindexing Tamino text fields

Hello, Op. env. Tamino 3.1.2.1 on Sun Solaris. We use full-text search for surname and company name search. Those names contain special characters like .,’-" We modified the ino:transliteration character set according to our needs, but this didn’t solve all of our problems. For example with <ino:character ino:class=“character” ino:value="."/> we have defined “.” as character, but the search ~=“A.T.*” didn’t return any result. Other problem, how can we reindex “text” fields, because there is a warning in Tamino doc: Warning: If you customize the transliteration, you MUST reindex all nodes that have the setting Search-Type=TEXT for all collections in the whole database. Afterwards, you have to restart the database server. The only way is to remove all those indexes from Tamino schema definition, modify transliteration characterset and then define all dropped text indexes? Thanks Mihaly

You don’t have to drop the index first. Make use of the admin command ?_admin=ino:RecreateTextIndex(…) as described in Tamino documentation, “Requests using X-Machine Commands”. Moreover, please be aware that Tamino 3.1.2. has long since been out of maintenance. It is highly recommended to migrate to the current version, Tamino 4.2.1. .