Profiling CAF application

Hi,

I am trying to profile a CAF application on WM10.1
I tried many different things, but I am not able to connect to my application with jvisualvm.

I have tried:

  • running jvisualvm from MWS/tools/diagnostics/bin but I do not see java process for MWS there
  • I have granted all permissions for Sys Admin role, including “Connect to JMX”, but after starting jvisualvm and connecting to localhost:5002 with sysadmin credentials I am still not able to connect. When connecting there is a dialog, that SSL will not be used, which I accept, but then it fails.

This is by default in the logs:
2019-11-25 19:17:30 CET (c.s.p.j.i.JmxConnectorImpl:INFO) [ManagedServiceFactory Update Queue] - JMX Server started on service:jmx:rmi://[0:0:0:0:0:0:0:0]:5002/jndi/rmi://[0:0:0:0:0:0:0:0]:5002/jmxrmi

then I changed host for JMX:
2019-11-25 19:27:07 CET (c.s.p.j.i.JmxConnectorImpl:INFO) [ManagedServiceFactory Update Queue] - JMX Server started on service:jmx:rmi://127.0.0.1:5002/jndi/rmi://127.0.0.1:5002/jmxrmi

but I still can’t connect.

In errors.log:
<log4j:event logger=“com.softwareag.platform.jmx.internal.JmxSinAuthenticator” timestamp=“1574706061423” level=“ERROR” thread=“RMI TCP Connection(4)-10.36.211.69”>
2019-11-25 19:22:05 CET (c.s.p.j.i.JmxSinAuthenticator:ERROR) [RMI TCP Connection(6)-10.36.211.69] - Expected String[], got null

Please help.

Regards,
Przemek

Please close it.
I was able to fix it by specifing IP address of my machine in my local network as JMX host (not localhost nor 127.0.0.1) and then use this IP when creating JMX connection.