Process model is not getting triggered


We have received an EDIINT message from the new partner via TN,

this EDIINT message is split successfully(to internal document types),conversation ID is also generated in TN and document is executed successfully(with Default processing rule). however, the corresponding Process model is not getting triggered.

  we have another partner who is already in production with similar setup. when i tried posting the message of existing parter, the processmodel is started. 

when i try with the new partner’s duns number, the same EDI message though processess successfully, the process model is not triggered.

 Could any one of you please help us with the above issue.

tried searching with similar threads and found no specific or helping.

appreciate your quick response.


Well a process model has a receive step, when you build and upload for execution it generates a trigger.

This trigger has some properties and conditions as when a docType matches.

The trigger must be defined inside a package on IS. I would suggest taking a look at the trigger definition on the working IS vs the failing one, maybe a condition is not met and that’s why it does not trigger.

Aside from that, make sure no other trigger is subscribed to same docType. It might be the case other trigger is subscribed to same doc and drains from queue faster? (I hope the word is drain, it always confuse me this pub/sub terminology :smiley: )


Hi Dev,

Thank you for your response. We have identified the issue and find the below resolution.


Intial step of the process models , there is fileter condition which is checking the partner information.

Thanks and Regards,