Problem with Tamino OCX and PutDocument method

I am using the TaminoX.ocx to insert documents into Tamino. The C++ code is

IXMLDOMDocument* xmlIn = new IXMLDOMDocument;
if (!xmlIn->CreateDispatch(“Microsoft.XMLDOM”)) { /* Some error*/; return; }

COleVariant vArg;

vArg = (LPCSTR)m_csPutFile;
if (!xmlIn->load(vArg)) {
/* Some error*/;
IXMLDOMNode node(xmlIn->GetDocumentElement());
m_lpDOMDocument = m_CTaminoX.PutDocument(NULL, node.m_lpDispatch);

I get a ‘Error: 8400
INOXJE8400 HTTP Error 502 Bad Gateway’, error.

What am I doing wrong?. Thanks again.

What does the web server logs say for the 502 error? What URL is being referenced?

I have tried this myself and it worked first time. What I can’t see from your example is what you are doing with the Tamino OCX. In my example, I call the Initialize() method, then use the PutcsDatabaseURL() method to set the URL of Tamino including collection name (e.g. http://localhost/tamino/mydb/mycol) and then invoke the PutDocument() method in the same way you have, i.e. 1st parameter null, and 2nd parameter a valid IDispatch pointer of the XML document.

Perhaps this helps…

a friend had a similar problem with the ActiveX component in VB - the problem is fixed now.

the 502 http error, occurs at his system each time he tries to commit tamino transactions without a StartSession or EndSession without a StartSession.