xml encoding

Hello all,

I have a problem with posting an xml document to Tamino with an asp script. When the node values are just ‘plain’ character sequences everything goes well. But when I have <, > and & (which are encoded into <, > and &) the posting doesn’t succeed (document incomplete error). This is also true for

Hi,

I gather from your post that you correctly escaped <, > in the content with & lt ; and & gt ; (spaces introduced for clarity), but when you say you work with ASP, it might be an issue with the transport protocol, HTTP.

As X-Machine commands like _process and the data to process are CGI parameter / value pairs, special characters need encoding using a facility like a URLEncoder.

See the problem: Your URL is …/tamino/db/coll?_process=& lt ; some text & gt ;,

and you get this: <ino:message ino:returnvalue=“8718”>
<ino:messagetext ino:code=“INOXPE8718”>Document incomplete</ino:messagetext>
</ino:message>

for now the very XML escape character ampersand (&) is interpreted as parameter separator of a CGI request.

Building the complete URL and then URLEncoding it should solve your problem.

Best regards, Andreas

I URL encoded the xml-document:
http.Send("_process="+Server.URLEncode(XML.xml));

best regards,
Pieter.

If you use the Tamino Jscript API or Active X
control the encoding is handled for you.

You can’t capitalise on all the work we spent debugging these :slight_smile: