problem by Web service call

Hello there,

Application Composer runs on Linux/Unix. I tried to implement the Java Processing.

But at the “Integrating Web service” there are following problems:

  1. whenn i use “new Mapped Web Service Call”,
    In the mapping view, the structure of the web service can’t be showed. See please the attached picture - marked with “1.mapped WS call”.
    what could the reason be?

  2. Then i tried use direct web service call,
    It shows, the two methods wsdirect_echoDirect_prepare() and wsdirect_echoDirect() are undefined. (see the attached picture - marked with “2. direct call”)
    Should I implement this two methods? Maybe can somebody show me codes of wsdirect_prepare() and wsdirect() from any examples?

can anybody help me? Thanks alot!

best regards

Hi Azamat,

  1. It could be related to your wsdl. Do you see any error messages in the Eclipse error view? Could you please send the wsdl file?
    It could of course also be that the mapping view does not work properly on Unix. The XCI Development environment is not supporte on UNIX. Development should be done on Windows, then export your project and import it in your UNIX installation.

  2. The sceen shot you sent looks good. You can also find a corresponding “wsdirect-sample” in the xcidemos2 project. The calls are used in the following way:


DataObject request = wsdirect_mymethod_prepare();	
// ... fill the request object with data if	
DataObject response = super.wsdirect_mymethod(request);

Best Regards,
Christine

Hi, Christine,

  1. Actually, this wsdl file is from example - xcidemos2. I have imported this demos in CentraSite and in Application Composer. the wsdl file see please attached file (DEMO_xcidemos2ServiceService.default.wsdl).

But i’m working also with a real SOA-project. I have generated the wsdl file from a IDL-file,which extracted from Natural. Then I have registered and published this wsdl file as web service in CentraSite. and now i should to integrate the Web service in application composer.
When i draged the Web Service from CentraSite (Metadata Tree) to the “Interface” of my project. There is one error in Error log:

No source node found in InboundMapping document

but it’s also stored in “interface”. (btw, with the demo service - xcidemos2Service there is no such error.)
However, i can’t mapping with both web services.

  1. I wrote these lines
DataObject request = wsdirect_mymethod_prepare();   
// ... fill the request object with data if   
DataObject response = super.wsdirect_mymethod(request); 

in my project, but it shows “the method wsdirect_echo_prepare() is undefined”.

I didn’t finde the source code of these two methods in exidemos2 project. :frowning:

best regards

see please the rar file
wsdl.rar (4.63 KB)

Hi Azamat,

If you have the xcidemos2 project imported into you Eclipse:
In Project Explorer go to xcidemos2/composites/wsdirect/methods
Double-Click “onCallWsDirectAppend”. The corresponding Java code will be opened in the Java Editor.

The wsdirect_* methods are automatically generated when you select “New Web Service Call” on the WebServices Node under a Composite.

If these convenient Eclipse Features do not work well under UNIX, better switch to an Eclipse under Windows. It is really simple to import/export Composer projects between different systems.

Best Regards,
Christine

Hi Christine,

I just want to tell you. This problem ist solved.

I just wrote the methods wsdirect_* in my code, and now I have called web services successfully.

Thanks for your support and helping! :wink:

best regards