Focus within TextGridSSS

When I used Application Composer for the very first time I had similiar problems.
First I had to delete this demo project, because it takes all of the resources of Tomcat.

My next problem was, that the Tomcat of CentraSite (which is needed by Application Composer) had wrong parameters which I had to fix manually. It makes sense to start CentraSite in debug mode with the startup.bat file. Go and find your startup.bat file. Set the Java Home + CATALINA_HOME params inside.

<---------------- SNIP -------------------->
set JAVA_HOME=C:\j2sdk1.4.2_10
set CATALINA_HOME=C:\CentraSite\CentraSite 2.1\tomcat

rem @echo off
if “%OS%” == “Windows_NT” setlocal
</---------------- SNIP -------------------->

Go find the catalina.bat file and check if everything is set ok.
I set there my own JAVA_OPTS like this:
< — SNIP—>
rem JAVA_OPTS (Optional) Java runtime options used when the “start”,
rem “stop”, or “run” command is executed.
set JAVA_OPTS=-Xms256M -Xmx256M
rem JSSE_HOME (Optional) May point at your Java Secure Sockets Extension
rem (JSSE) installation, whose JAR files will be added to the
rem system class path used to start Tomcat.


Now start your CentraSite in this special debug mode and retry your Eclipse IDE with Composer. Does it work now? May be you see something in the console?

“No target Service to authorize for”
could also mean that you are missing the BPELO sequence. Did you try out the special order of build.xml scripts?

Hope that helps!
Cheers, Konstantin Kirsch