[POP.005.0026] Must have at least one server node defined

Hi All,
Have installed a fresh copy of wM8.2.2 in RHL server through below script. I just need Broker, IS, MWS & Developer.

java -jar SoftwareAGInstaller201202_xx.jar -console -readImage /SoftwareAGInstallersAndImageFiles/RHELx86-64.zip

Created tables component wise through scripts like below:

./dbConfigurator.sh -a create -c ISCoreAudit -v latest -d sqlserver -l ‘jdbc:wm:sqlserver://ssssssssss:1433;databaseName=xxx’ -u aaa -p bbb.

Started IS,experieced some issue in IS logs after which I dropped all tables component wise and created tables once again on the same DB based on Product wise ( IS & MWS ).

Started IS which came up and running fine. But after starting MWS getting below error msg:

com.webmethods.portal.PortalException: [POP.005.0026] Must have at least one server node defined
at com.webmethods.portal.system.cluster.impl.ClusterProvider.validateConfiguration(ClusterProvider.java:552)
at com.webmethods.portal.system.cluster.impl.ClusterProvider.init(ClusterProvider.java:259)
at com.webmethods.portal.system.init.impl.DefaultPhase.initComponent(DefaultPhase.java:107)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:602)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:170)
at com.webmethods.portal.system.init.impl.DefaultPhase.init(DefaultPhase.java:49)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initComponent(DefaultPhaseProvider.java:262)
at com.webmethods.portal.system.impl.BaseProvider.ini

Kindly suggest me how to resolve this. Also, if I want to Un-install any component through script, how can I do the same as I don’t have GUI capability to get GUI wizard in my RHL server. Thanking you so much for your help & time.

Thanks,

You should use different users for each product which it makes it easier to verify the tables.

Did you recreate your MWS-instance after recreating the tables?

looks like the MWS User Management is not correctly configured.

For uninstalling webMethods components by script:
In the installation directory under bin-directory:
./uninstall -console

For the missing GUI capability:
If you are able to allow X11-Forwarding in your SSH-Tool, you can do the following:

  • Download a XClient to your local machine (like Xming, MochaX11 or MobaXterm per example).
  • Connect your RedHat via SSH with X11-Forwarding enabled
  • check for a file .Xauthority in your home-directory
  • check that the environment variable DISPLAY ist set
  • start the GUI you want.

Regards,
Holger

Thanks Holger for your reply.

I have Xming in my local but I don’t have X11 packages in RHL box. I tried to reach Unix admins but no help from them, replied saying do by myself. I tried to
download, install but got errors while installing :frowning:

I tried to find uninstall but could not able to locate. Can you share me the exact path.

I will check and update you whether environment variable DISPLAY ist set or not and try to enable it.

The uninstall is located at the following path:

/bin/uninstall

On our Solaris boxes we have X11 available by default.

What is the error you get during the installation?
Probably you might be missing the proper rights to install.
Maybe you need the possibility for “sudo root” to be able to install additional packages.
Check with your admins.

Regards,
Holger

Holger,

I resolved the issue by doing the following.

Ran mws.sh, deleted defaulte instance, created a new which solved the issue. Thanks once again for your help.

Hi RP,

I am glad to hear that you have solved it finally.

The MWS-instance on the file systems contains somewhere a node-identifier consisting of the (short) name of the box and generated number.
If the appropriate node is not listed in the cluse-config.xml file (usually stored in DB), but sometimes it is additionally stored in the configuration directory of the instance, the MWS will not start with error message mentioned.

See MWS Administrators Guide about getconfig-/putconfig-functionality for details about the config-files and their storage locations.
I.e. locally stored files override the versions stored in the DB.

Regards,
Holger