Order a free T-Shirt

Order your Free T-Shirt via Enterprise Web Services.

So you’ve had a chance to experiment with webMethods’ latest Web service capabilities. Let’s put your skills to the test - take the webMethods EWS Challenge!

To get your free t-shirt, you must connect to a couple of Web services to (1) submit your order and mailing address and (2) retrieve your invoice. Successfully order and retrieve your invoice using your EWS Central email address, and we’ll ship you the t-shirt.

How easy is that?!

This promotion is for a limited time and for a limited number of entries. The webMethods EWS Challenge opens Oct. 9, 2002. The promotion ends after either the first 100 correct entries are received or by 5:00 p.m. United States EST, on Dec. 31, 2002.

Learn more, including contest rules and eligibility by clicking the “Order a free T-Shirt” link on the home page of webMethods Enterprise Web Services Central.

Help for the webMethods EWS Challenge–Order a free T-Shirt–is provided here in the Web Services forum. Post your questions and answers in this thread.

Hi,

I have created and linked all the required services for this exercise but keep on getting the error message 'REJECTED - Missing required field ‘PONumber’.

I have checked the sendPO web service to verify that the PONumber field is in the input structure called ‘header’ for this service.
I have also debugged the service to verify that my email address is stored in the mandatory PONumber field in this structure and that all other required data is populated.

Could there possibly be a bug in your code or have I missed something?

I am trying to create web service connector but it fails with folowing message: -

[BTLINTG.0013.0001] Server connection to ‘localhost:5555’ lost: Reason unknown. Try restoring session later to save changes.

No error on server console.

What could be the reason…

Thanks,
Rajan

I am having trouble negotiating with my proxy server.
I have installed as described and set the proxy server in IS (for HTTP only), am not clear if this done correctly, for example have not set the user and password as don’t know these…
When i TRY AND CREATE A WEB SERVCIE CONNECTOR i GET THE ERROR

Host name could not be found on the network.

pLEASE ADVISE

Same error here, even after applying the required patches.

same error here

I checked the server logs and found this message everytime I tried to create a connector:

2002-10-10 12:55:50 EDT com.wm.app.b2b.server.ServiceException: [B2BSERV.0085.9071] Method not found
at wm.server.ns.getMethod(ns.java:2587)
at java.lang.reflect.Method.invoke(Native Method)
at com.wm.app.b2b.server.JavaService.baseInvoke(JavaService.java, Compiled Code)
at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java, Compiled Code)
at com.wm.app.b2b.server.comm.DefaultServerRequestHandler.handleMessage(DefaultServerRequestHandler.java, Compiled Code)
at com.wm.app.b2b.server.HTTPMessageHandler.process(HTTPMessageHandler.java, Compiled Code)
at com.wm.app.b2b.server.HTTPDispatch.run(HTTPDispatch.java, Compiled Code)
at com.wm.util.pool.PooledThread.run(PooledThread.java, Compiled Code)
at java.lang.Thread.run(Thread.java, Compiled Code)

I was able to succesfully complete the challenge on Wednesday.

I used version 6.0 FCS of Integration Server running on my laptop. I did not have to configure a proxy server.

Here are the basic steps I followed:

  1. Created a new packaged called “EWSChallenge”
  2. Create four folders in that package one for each of the services (this is not required, but helps keep the generated records and services separated in order to make it easier to understand the components of each web service).
  3. Created one web service connector in each folder by using the New Web Service Connector Wizard.
  4. Step one of the Wizard prompts for folder name. I chose the corresponding folder I created in step 2.
  5. Step two of the Wizard prompts for a local file name or URL of the WSDL file. I used my browsers copy shorcut function to copy “Get WSDL” shortcut from the “The Services” section of the “EWS Challenge Instructions” page and pasted it into the text box.
  6. Clicking on “Finish” button created the web service connector. I encountered no errors trying to generate the connectors for any of the servies.
  7. At this point I reviewed the home page for each web service to identify required fields. The main thing to remember is to use your WM Advantage email address as your PO Number.
  8. I ran each service interactively from the Developer tool (Test Run) to complete the steps of the challenge.

This doesn’t help address any issues with proxy servers or specific service packs to IS 4.6, but I did find that all services worked as advertised for me.

My total time investment was around 10 - 15 minutes, but I already had IS 6.0 FCS installed.

Hope that helps! Good luck all!

Mark

I was able to succesfully complete the challenge.

I used version 4.6 of Integration Server. I did not have to configure proxy server. I had SP1 and Fix 49 installed on my server. Also, I had to install SP2 for my 4.6 Developer.

The basic steps were very similar to what Mark had listed.

Hope this helps!! Best of Luck !!

Regards,
Saurabh.
(sm195@lucent.com)

I have looked into this and have not been able to figure out the problem why the web service connector wizard is not functioning. Has anyone else had any luck?

I have installed wM Integration Server and Developer and now try to create a new Web Services Connector. The following error occurs :

com.wm.lang.wsdl.WSDException: [B2BCORE.0092.9102] http://ewsdemo.webmethods.com/WmEWS/directory/service-overview.dsp?interface=contest.idemo.supplier&service=ge;etCatalog: not a valid web service description document

Note that I suppose that I’m not using a proxy to access to the Internet (IE is configured to automatically detects LAN settings).

Thank you for your valuable help.

Micha�

That URL is for the overview of the service. You should use the URL for the WSDL. For the getCatalog service the URL is http://ewsdemo.webmethods.com/WmContest/wsdl/getCatalog.wsdl.

Thank you for your help. I must have been tired to do such a mistake. I’m
proud to announce now that I have accomplished the challenge and waiting
for my t-shirt to be shipped.

I’m seeing this also…what’s the solution?

I completed the webMethods EWS Challenge in about 10-15 mins time.

Steps followed:
I downloaded these files. IntegrationServer4.6_SP1_en_US
Developer46_en_US
Installed them successfully.
Downloaded the wsdl files.(i.e i saved the wsdl files to the local disk)
Created a folder called EWSChallenge under default package.
Created the webservice connectors for all the wsdl files.
After this i invoked the webservices one by one following the instructions…

Hope this information will be usefull
regards,
Venkatesh

hi,
I trying to get t-shirt from webmethods site. what else i need to get it. i downloaded integration server and developer weblogic connector

thanks
murthy

hi murthy,
u need to install webmethods integration server and developer, create webservice connectors and submit the purchase order for a t-shirt thru webservces… u can refer to my earlier message for more details

thanks and regards
Venkatesh

I ahd installed Webmethods Developer and after installing I am having login problems…

Could anyone help me on this

Akrishnan

I managed to connect integration and web methods developer. here is the issue:

  1. If i connect the get catalog URL , I get a time out error
  2. If I connect the getcatalog.wsdl from my local directory and when i try to run the services I get the msg as “com.wm.app.b2b. server.ServiceException: java.io.InterruptedIOException: Operation timed out: no further information”

Is there anybody can help me.

The logon settings is
localhost:5555
username: Administrator
Password: manage

Thanks
ananth777@yahoo.com