NTLM Authentication issue

Hi

We are Consuming a Web service and the provider is hosted in Windows platform. We are getting the below error message while trying to call the web service. Our Integration server hosted in Linux environment and version is 8.0.1. We are able to invoke the same web service using SOAP UI Tool. Initially we had the same problem in SOAP UI but after adding the Domain name in SOAP UI then it started working fine.
Can you please let me know how to add Domain name while calling a web service. Please let me know if there is any other way to invoke the web service.

I gave correct credential at Transport level (auth/transport/user) and Message level while invoking the web service connector.

Error Description:

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.

Thanks & Regards,
Pradeep Kumar K

Hello Pradeep,

were you able to solve this issue? We are currently facing the exactly same one and I haven’t found much about how to proceed.

Thanks!

Have one of you found a solution to this problem yet?

Reponse is greatly appreciated.

Thanks,
Sundar

Hello,
We also faced the similar issue while consuming sharepoint web services from our IS (8.2.2) hosted on Linux box.
We tried to overcome it using JAAS featured provided by IS but couldn’t get it to work. Further enquiry from SAG revealed that NTLM is supported only if IS is also hosted on a Windows platform.
In my knowledge as of now there is no support for NTLM based authentication from IS hosted on Linux/Unix box.

Regards,
Manoj

NTLM v2

Have you tried the passing the username as

domain\username