Not seeing New -> WSD option in designer 10.1, how to check installation changes needed ?

We are using web methods TN, Broker(pub-sub) and Designer for EDI transactions. Since we are using pub-sub model, we dont have any web service calls, but When I wanted to try a web service as part of POC, I am not seeing new -> WSD option. I thinking it is because of installation difference, But how could I find which are all needed to be installed to enable option to create WSD and expose as web service. Any help is highly appreciated. Thanks in advance!

Hi Pradeep ,

The option ‘New->Web Service Descriptor’ should come , if the installation has ‘Service Development 10.1’ included while installing Designer.
You can check that if ‘DeveloperPlugins.zip’ is available by navigating ‘SAG_Directory\Designer\updates’ folder in your environment.
If not present you can install that using Software AG Installer and select Designer->Services->Service Development 10.1’.

Please let me know if it work.

Thanks
Anasua

Hi Anasua,
Thanks for sharing your thought. I checked in software AG installation directory and I have DeveloperPlugins.zip in the path C:\SoftwareAG101\Designer\updates\DeveloperPlugins.zip. Even then I am not seeing New -> WSD option. I tried comparing my “Help -> Installation Details” with my colleague installation Details and I didn’t find anything missing.

Only difference between them and me is they all are upgraded from 9.8 version to 10.1 but I directly installed 10.1. My infra team says both are separate installations and it is not like replacing 9.8 with 10.1.Any help is highly appreciated. Thanks in advance!

Hi Pradeep ,

Would you mind to share a screenshot of your designer.

Thanks
Anasua

Hi Pradeep ,

I have just installed 10.1 designer in my system. The ‘New->Web Service Descriptor’ option is coming as expected.
Can you please check if your workspace is in ‘Service Development’ perspective . There should be a blue arrow symbol in top right corner. If not you can change from the top menu ‘Window -> Perspective -> Open Perspective -> Other -> Service Development’.

Thanks
Anasua

Thanks Anasua for your quick turn around. You asked for screen shot

“Would you mind to share a screenshot of your designer.”

Please find the attachment and please let me know if you could able to download and see.

I am not sure by screenshot of designer what you mean in specific, please let me know if you need anything more.

Hi Anasua, In-turn to your comment below,

I been working in service development perspective for developing flow service which you can see from the screen shot attached in my previous post.

“I have just installed 10.1 designer in my system. The ‘New->Web Service Descriptor’ option is coming as expected.
Can you please check if your workspace is in ‘Service Development’ perspective . There should be a blue arrow symbol in top right corner. If not you can change from the top menu ‘Window -> Perspective -> Open Perspective -> Other -> Service Development’.”

Thanks,
pradeep.N

Hi Pradeep ,

Thanks for sharing the screenshot.
I have observed the ‘REST API Descriptor’ option is also not available for you.
Could you please tell me what is the fix level you have in your IS ?

Thanks
Anasua

Hi Pradeep ,

Good to hear that your issue resolved.

Thanks
Anasua